Pozyx to pixhawk connection (non_loiter mode)

Configuration through the Ground Station

Ensure that Copter-3.5 (or higher) is loaded onto the flight controller and connect with a Ground Station (i.e. Mission Planner).

set BCN_TYPE to 1 (means using Pozyx system)
set BCN_LATITUDE, BCN_LONGITUDE and BCN_ALT to match your actual location. Getting these values exactly correct is not particularly important although getting it close is required in order for the compass’s declination to be correctly looked up from the small database held within ArduPilot.
set BCN_ORIENT_YAW to the heading from the origin anchor to the 2nd anchor. One way to capture this value is to stand at the origin holding the vehicle so that it’s nose points towards the second beacon. Read the vehicle’s heading from the HUD and enter this value into BCN_ORIENT_YAW
set GPS_TYPE to 0 to disable the GPS
set ARMING_CHECK to -9 to disable the GPS arming check
set SERIAL1_BAUD to 115 to set telemetry1’s baud rate to 115200 (if using Telem2 set SERIAL2_BAUD instead)
set SERIAL1_PROTOCOL to 13 to enable reading the IndoorLoiter2 protocol (If using Telem2 set SERIAL2_PROTOCOL instead)
set BRD_SER1_RTSCTS to 0 to ensure telem1 does not use flow control (If using Telem2 set BRD_SER2_RTSCTS instead, not required if using Serial4/5)

I have tried to do Pozyx configuration through ground station for this your non-GPS loiter mode using BCN parameters. However, my Pixhawk is not compatible for its developer software. Is there alternative for the mentioned issue? Thank you.

What do you mean by “my Pixhawk is not compatible for its developer software” ?
Just download ArduCopter 3.5.3 firmware to your Pixhawk.

Thank you so much for the reply. With this configuration, is it possible to perform autonomous flying?

It should be possible, yes.

Good Evening. I have tried to follow your method, unfortunately it still doesn’t work. Is there any other alternative? Thank you so much

Sorry, I am new to all this but got a request to help a friend on this. Where can I set the parameters in Mission Planner? Can’t find them in the “Full Parameters List”

Update to Arducopter Firmware 3.5.5

Thanks found aut that the old Ardupilot firm does not support 3.5.5. Got a Pixhawk instead and it works. Trying out Mini Pix …

If I keep getting the the range of the anchors that is exceptionally large the Pixhawk will not take in the value. Any insight as to what causes the error in the range to the anchors?