Power drop in one of the motors at full/big throttle


My tricopter (based on pixhawk) has an issue when a rear motor is not catching up with front two motors during max/big throttle in stabilize mode. It results in a pitch backwards initially and after a moment pitch corrects itself.

This issue isn’t noticeable in loiter and alt hold (probably due to smaller accelerations), but and it seems to behave normally during rapid pitching and rolling in those 2 modes.

Things that i’ve tried and that are not a cause of the problem:

-Motors and controllers itself are working properly, timing is fine, no soldering issues.
-Battery seems to supply power normally as well.
-I’ve changed power wiring to rear for a thicker one.

Judging from logs, it seems that ardupilot is sending correct signals and it is actually increasing motor speed signal when detecting rotation.

Have anyone dealt with similar issue or does anyone have any ideas on what might be a problem here? Thank you for any help.


Have you gone through the autotune procedure? If it works fine in loiter, it’s possible the PIDs for stabilize mode aren’t set properly. I just tune up a new copter in 3.4 and it worked great.


Hi David,

Sorry for late reply. Yes I tried auto tune, but I tuned my PIDs manually anyway. Signal outputto motors from ardupilot is fine, as I would expect, so gains are unlikely to cause this issue.

Can you post a log from flight where this is happening?

A bit hard to guess from your description.