Servers by jDrones

Post Withdrawn - Thanks

Withdrawing the post.

Dude, are you trolling or serious ? :slight_smile:

I think he means a Betaflight question in Ardupilot Discourse!

Take it to a betaflight forum, dude.

I know nothing about Beta flight. Which forum is most active?

This one? https://intofpv.com/forum-betaflight-cleanflight

I have no idea, but asking about betaflight here, is like asking a an iOS question on a linux forum.
It’s nothing about policing, but a little common sense and etiquette.

The question is posted inside general section and its within guidelines.

And I know my etiquettes but you on the other hand try to make fun of of others in the past. So perhaps learn some manners and you can stay out my posts.

Thanks…

@Redshifft have a look at this please as I know you have set it up in BF and INAV.

Thanks Malcom. My son will be happy :slight_smile:

Here is where I would go.

https://www.rcgroups.com/forums/showthread.php?3371977-DJI-Digital-FPV-System-Owners

@UAVSkies
Just looking at your first post I would think your problem is you have not turned on MSP for the UART you have connected to the DJI AU. Should be in peripherals.
I will say at this point I do not use the DJI RX part into the FC and could not honestly say whether you can share the RX uart for MSP at the same time, I would certainly doubt it as the MSP is 2 way.

  • Find the RX in and connect the DJI RX out into that
  • Select a free UART and set that to MSP for the DJI OSD
  • OSD does not need to be on in BF as the MSP is working in the background before the Telem/osd output as such, however you need that on if you want to move OSD characters around in the BF OSD configurator.

PinOut on your FC to the DJI AU :-
1 VDD 8V/2A
2 G Ground
3 T1 UART1 TX
4 R1 UART1 RX
5 G Ground
6 R6 UART6 RX

Ok, you need to turn on MSP for UART 1 in the Peripherals Column and you will be good to go :slight_smile:

Thank you for your help.

Which one is MSP from the drop down?

Telemetry Output is where you find this.

nope…unless its labelled differently.

Actually it is staring at you. Configuration/MSP. Enable and set the correct baud. No need to select a telemetry option as such. Looks fine.

USB is connecting with MSP, MSP is first column. turn of RX in UART 1 and put it in UART6

Servers by jDrones