Servers by jDrones

Post-landing flip with 3.4.2-rc2

Hi,

I’ve just completed a new TBS Discovery Pro build and went for first flight and autotune session. The flight was clean from takeoff, roll autotune has completed, then I switched to LAND to change the battery. The copter landed, and then took off again, went to the side and flipped. As you can see from the log, neither landing detection nor crash detection worked properly and I had to disconnect the battery with motors still spinning. I hit the left stick to disarm position when it took off again and held it there, but that did nothing. Can anyone please help me understand the problem?

Frame: TBS Discovery Pro quad
FC: 3DR Pixhawk
GPS: M8N
Log file: https://drive.google.com/file/d/0B3-JjJykr-BdRmJjMDFXY2RGZGc/view?usp=sharing

Regards,
Arthur

Before I take a look at the logs, I would recommend to have a switch on the radio dedicated to Emergency Stop

Have you checked the Auto Analysis from MP ?

Log File C:\Users\Luis\AppData\Local\Temp\tmp3FB1.tmp.log
Size (kb) 11775.404296875
No of lines 147761
Duration 0:06:04
Vehicletype ArduCopter
Firmware Version V3.4.2-rc2
Firmware Hash b185c5d3
Hardware Type 
Free Mem 0
Skipped Lines 0
Test: Autotune = NA - 
Test: Balance/Twist = NA - 
Test: Brownout = GOOD - 
Test: Compass = FAIL - Large change in mag_field (78.13%)
Max mag field length (842.64) > recommended (550.00)
Test: Dupe Log Data = GOOD - 
Test: Empty = GOOD - 
Test: Event/Failsafe = FAIL - ERR found: FS_THR 
Test: GPS = GOOD - 
Test: IMU Mismatch = FAIL - Check vibration or accelerometer calibration. (Mismatch: 5.38, WARN: 0.75, FAIL: 1.50)
Test: Parameters = GOOD - 
Test: PM = NA - 
Test: Pitch/Roll = NA - 
Test: Thrust = NA - 
Test: VCC = WARN - VCC min/max diff 3.09214v, should be <0.3v

Re the “took off again”, this is likely caused by ground effect. There’s a wiki page here on how it can be enabled but in short, there’s a GND_EFFECT_COMP parameter that can be set to “1”: http://ardupilot.org/copter/docs/ground-effect-compensation.html.

It’s possible that this is also the cause of the flip. The issue likely comes from the autopilot not recognising the landing so it keeps trying to control it’s horizontal position but it can’t because it’s legs are on the ground.

@rmackay9

I see a Radio Failsafe event right before it goes nuts. On a TBS discovery -which has low ground clearance the Ground Effect could also play a role. We tested this on a TBS Discovery of mine, and the parameter solved the GE effects.

I think all the horrible stuff at the end is after the vehicle has flipped over. So tons of bad things are happening - for example vibration levels are incredibly high but this is likely just the vehicle dancing around upside-down on the ground. In this state the landing detector certainly won’t triggger. The crash check also won’t work because if it sees accelerations of >3m/s/s it thinks the vehicle is still moving around so it’s still trying to fight to right itself.

Thanks guys for the analysis!

@LuisVale I unmarked your solution because, as @rmackay9 says, there was huge vibration after crash due to broken props. The radio failsafe was after it turned over: a prop caught one of the antennas and ripped the RX off. As for the emergency stop, unfortunately my TX is 6ch, and the only extra channel I have was used for Autotune switch. If I use Autotune as a flight mode, will it behave like AltHold, or like Stabilize?

@rmackay9, so GND_EFFECT_COMP reduces the weight on the barometer readings. Does it mean that landing detection will happen on touchdown kick from accelerometers or some time after zero vertical speed? How many seconds must the copter be stationary to trigger land detection? Has the landing detection code changed from 3.3.3?

I’ve flown another Disco with 3.3.3, which had some legs so it was standing >10cm higher from the ground, that’s why I never thought of the ground effect. There was a case when it jumped up and landed again, but the attitude was perfectly level. Never did it try to lean to the side when landing, on the opposite, it was staying level on an uneven ground until land detection and disarming.

@LuisVale The new Disco Pro also had some legs, but these are just 6cm higher than stock. Were those too short to avoid ground effect?

I still can’t figure out why it would lean to the side instead of jumping right up.

Sorry for OT.
Is it ok to land with LAND or RTL (with ch7/ch8 switch in the HIGH position) after autotune has completed ??

Oh, I’d like to know too! I have an “Autotune Off” message when I hit Land, but the landing detection didn’t work, so unfortunately I don’t know if it would save or not.

I’m still looking for answer as for what really happened. The Land mode wiki page says:

Copter will recognise that it has landed if the motors are at minimum but it’s climb rate remains between -20cm/s and +20cm/s for one second. It does not use the altitude to decide whether to shut off the motors except that the copter must also be below 10m above the home altitude.

So I’ve plotted NKF4.PI(to see that EKF0 was active), NKF1.VD and CTUN.ThO:

I see here that in period from 473.5s to 475s the throttle output was at 0 and climb rate was less than 20cm/s. Is this not sufficient to trigger landing detection? What other conditions should have been satisfied?

Also the page says

Upon reaching the ground the copter will automatically shut-down the motors and disarm the copter if the pilot’s throttle is at minimum.

Is this a prerequisite for landing detection, or just for disarming?

Hi,
since there is a pixhawk2, AC becomes more and more crap!
Everything about Problems, you can read in Forums, will happen to my pixhawks and apms.

Don’t like it anymore, i’m still looking for better FC’s. This is since V 3.4!!! Everything worked
great until 3.3.3…

Ahh, come on presario62. Arducopter 3.4.2 is amazing.

Servers by jDrones