Possible Bug in TLOG GEO Tagging

I normally use the bin log file to GEO tag my images. But I’ve been plauged with bad logging which truncates the bin file. So I tried using TLOGs to GEO tag my images. It looks like the lat and long are missing a decimal after the degress. See attahed image. TLOG attached as well for reference.

that does look like a bug. i will check it out

Hello Michael,

Sadly, I continue to lose the battle with logging. I’ve been chasing a bad logging error for months. Some flights are unaffected while other are. Yesterday, I flew and had no problems. Today I flew and got a bad logging error the moment I armed. Not sure what is causing this error. I’ve replaced the SD card numerous times and even swapped the pixhawk flight controller. So something in my set up must be causing the logging error. I am using Astrx as my primary GPS and backed up the a standard 3dr GPS unit. I am sending a CORs correction to the gps board via mission planner using GPS inject. Same set up both days, one day no problem the next day, bad logging, Any ideas?

Back to the topic of the thread. Since I don’t have a bin or log file I tried to GEO TAG with the tlog. Not sure if you ever looked at this bug, but if you did, I wanted to let you know the problem persists…no decimal.

Text file attached.


Dave data for exif.txt (7.9 KB)

Any update on this bug? Mission planner is tagging flight mapping photos this same way.

this was a bug, and I believe it is fixed in the current beta.