Possible Autotune bug

Tried out Copter 3.4.1 today on my TBS Discovery with Pixhawk. Selected YAW only for Autotune and launched. Went to AltHold and selected AutoTune. Instead of Autotune doing the YAW program, it started doing the Roll program. I also noticed that Autotune was not shown on the Mission Planner (linked via Mavink 915)

Please post a log, without it it’s difficult to help.

To correct the record, I went out and retested with exact same conditions, (Autotune - YAW only). Autotune worked perfectly (and did a really nice job). I’m sure there is a way to get a message on Mission Planner when Autotune is complete but I heard the completion tones and saved settings.

If you click on the “messages” tab in the quick view, it will have messages that sometimes don’t get to the HUD. “Autotune:Success” will show with the tones you hear. When you land and disarm to save the new settings the message tab will indicate so by the message “Autotune:Saved Gains”. I just got done doing a yaw tune this evening myself.