Servers by jDrones

Position Hold causes uncontrolled fly-away with climb at max current

Hi,

I need help here. I am trying to tune a small racer vehicle on pixracer controller.

It exhibits OK behavior if not pushed. Despite all efforts it appears that some issue persists where in the position hold mode when it is pushed to go fast in the straight line with no additional input on throttle it suddenly causes a fly away with a maximum current given to motors, it causes sudden uncontrollable climb that i have to kill from the radio.

in the attached logs at mark 36 it is seen how current suddenly spikes up from normal in-flight level of 16-20A all the way to the max of 130A.

I tried to move compasses around, enable and disable external compass, re-calibrate all, use EKF3 , EKF2 - it changes a bit but overall still not good.
In the example provided vehicle uses internal compasses only. i see in the auto analysis it says mag filed went up to 4000. not sure what causes what anymore. it makes no sense to me - but may be somebody will see right away what logic looses its mind in there.

I also noticed in the straight line pos hold acceleration it starts to oscillate while in stable loiter it is very calm with almost no vibrations. soft props may be an issue here as well but even if it is vibrations it does not explain this crazy shoot out into the sky.

alt hold and stabilize do not have this issue. only in the position hold.

https://drive.google.com/file/d/1_Jp1l9HMp9bpvg52wig3bhtBYa9Cku7t/view?usp=sharing

Paul; No expert, but it sure looks like vibes are spiking to me. When Ch 3 goes High, your Vibes increase and Clip. Drop throttle and it settles down.
High “Z” vibes WILL cause a rapid climb from what I have experienced and read.
I found a lot of the small props ( 5"&6") are way too flexible on my small quad (250) at high speed. I have played with my PixRacer vibration mounting to help this, but a stiffer prop makes a big difference in vibes at high speed.
Do a short high speed run in Stabilize and look at your vibes. That may help narrow it down.
Joe

i did run in stab on 2 blade props - it was ok…it is in the same first log. and stab current is way higher than pos hold - as it is not restricted, that is why it was was so odd to me.
and even if it was indeed caused by Z vibes - this climb was like a switch turned on with max current - weird. i had bad vibes before on this model with one bended prop - in pos hold it is supposed to cause EKF failsafe with landing - and it did it fine, several times. i then replaced that prop and got this shoot into sky, twice.

So, I just now did the same test again but removed 7" gemfan 2 blade props and set drone on 6" Lumenier 3blade gate breakers. Behavior changed completely, i can tell it flew way better and had no oscillations, at least no audible ones. can it be because motors span faster? those are 2300k motors after all, they want go fast. may be with 7" props it was out of proper zone?

looking at vib 3.3 chart from log below i cannot say this looks much better than the previous sample. and z vibes seem to be comparable. but, like i said - in the straight line shoot drone did not scream oscillations and went well straight like accelerating and maintaining altitude. in first test it was all over the place up and down. so something was off, but what? blades were new in first test - not bended and seemingly well balanced, as stable loiter was very steady.

https://drive.google.com/file/d/1227zWlc1-m0ipeOwI1dkrMwfVEoKkhaG/view?usp=sharing

But there was nothing like that in the previous glitch with drone giving up suddenly 130A max current to all motors. i really cannot comprehend what could possibly do such a stunt, what combination of cafeterias would be able to cause this?

i do not see any error or msg at mark 36 on first log where current shows that spike - and i killed motors in .6 sec after it screamed and jerked into sky…

but, on those 3 blade gate breakers i flew faster now and way more aggressive, did circle and stab and alt hold - all was perfect. i do not know what to think, as it is unsafe to fly this thing anywhere as it is armattan - unbreakable frame, but i cannot fly it anywhere if it may jerk up 100m up and then be dropped down on the populated area. plus i cannot think of anything acting like that since may be very first 3.1 arducopter RC versions - pos hold was extremely reliable since 3.3 for me, i never had anything weird like that.

other part that bothers me - i did not alter after autotune that was done twice the values of ATC_ACCEL_x_MAX that are set now way too high by the autotune, i think. but, it flew ok and responded very well.
go figure.

Take a look at this:

It’s how I tuned mine, by lowering starting PIDs and changing filters.
There are many listings about vibes and their effects. Do a search and you will see a fast climb out is not uncommon with high vibes.

I have never run more than 6x3 2-blade props, and I have 2300 motors as well.

Your 1st flight log has many EKF errors. Bad variance, failed to int, and a few GPS glitches also. The last one triggered a Land failsafe. On all my Pixracers I have disabled both internal compass’s and only used external. I have had no luck with Autotune on small quads. On my 210 Pixracer based I just tuned manually.

‘The last one triggered a Land failsafe’ -it is a response to a kill switch i hit. current curve begins 0.6 sec prior to that moment. as it can be seen current curve dies at same time with the land mode goes on, but it is no Land - it is activation of the mode 31 on channel 8. ‘EFK variance’ that came with it was due a nice subsequent drop from 60-something meters of altitude into the ground of the football field.

EKF errors are indeed an issue. But external compass on the mRo M8Q refuses to cooperate.
https://store.mrobotics.io/product-p/mro-ugps-samm8q-01.htm

No matter what setting used for it, it produces error compass variance consistently, in combination with other compasses or alone - does not matter. in real view mag field with motors under load on it is also higher than on internal mags.
I was able to make it work with yaw180 setting for orientation - no obvious reason for that, but even with such settings it calibrates with pretty large offsets - above 600 on z and 450+ on y. so i gave up on it and so far i see no issues, as i flew in simple mode in all tests and it is not getting messed up, and orientation is also seemingly consistent. so internal mags seem to work ok.
As a GPS this unit works fine for its form factor, so i do not want to replace it yet. GPS glitch msgs are irrelevant, stability of pos hold is perfect.

With all that in mind at position 36 where current spiked up - there were no errors, but it still happened, so, got to be a reason…

Your climb problem is straight out vibration.

Had exactly the same problem with a couple of PixRacer boards in ZMR250 frames.
Flew around fine until you gave it the gas and suddenly went straight up.
Remounted the FC in a suspension frame as I do all my bigger builds and all is well.

In general tuning it seems to perform quite well, with actual following Des. quite closely.
Your Mag fields are pretty bad however and the spikes on power increase will not do you any good in any guided mode.
No wonder the EKF is spitting the dummy.


If you want to use guided modes in this build you will need to rethink your wiring setup.

Agreed, i already did it twice, will have to think of something else to do there…

FC right now sits on rubber grommets,


i will try to put it back on rubber post mounts and will re-test.

https://drive.google.com/file/d/1j3ey2zsMLNklO_wTeMO9-ZGB0Owm3zAL/view?usp=sharing

https://drive.google.com/file/d/1Mho3spl4Df2ap7A__6IhynKdnbe3nRwh/view?usp=sharing

i have altered mounts now, got it again on rubber posts. on a model i built 2 yr ago similar mounts produced inferior result, that is why i used rubber grommets instead, but, will try to test it this afternoon, if time permits.

not sure how to redo whole wiring, probably will need to ditch acsp4 board and get different one and make all wires go 100% under carbon plates.

I put the ACSP4 under the bottom plate allowing for more space for a ball type FC mount. Unconventional I know but it works well.

yeah, i thought about that… i am trying to keep chameleon to look like one, it is a pretty good looking frame, but, will need to think of something.

most likely i will use this:
https://store.mrobotics.io/product-p/mro-acsp7v10-mr.htm

and will need to solder in ESC feeds directly from it, like octopuses arms, will think about it…

I notice in the 1st photo you have the GPS pitched up at some angle but your COMPASS_ORIENT parameter is at 4 (Yaw 180). Is this what I’m seeing?

on other question from pictures i posted above - what orientation setting would compass in this gps unit need? arrow on the unit it facing forward. plate is about of 40-45% tilted. I would think yaw45, right? it refuses to work this way.

when it was mounted flat on the arm with arrow also pointing forward - it accepted yaw180 to be in line with internal compasses, also not clear why as actual chip on the gps board is aligned same way with compass chip on pixracer and dot - 1st pin is oriented same exact damn way. but, it was absolutely refusing to work with orientation set to 0 and i would see mag readings not to align in real time view on tilting it. it got workiing with yaw180 orientation, somewhat, but assigned very large offsets. The position where it is now is the best spot on this frame to get good gps signal almost immediately, so i do not want to move it anymore.

But, with 45% tilt of the plate under and presuming original yaw180 setting - what orientation would this thing supposedly accept? so far all attempts to use that compass generate red EKF with compass inconsistent cries, go figure what is inconsistent with what if it gets chosen as the only one to be used in the configuration.

it was sitting flat on the rear arm before very close to the frame - i just posted about that. with this pitch now - what orientation would it take?

No, Yaw 45 is what would be required if the unit was mounted flat and rotated in the yaw axis 45°. What you have is either Pitch 45 or Pitch 315 (assuming 45° from horizontal) not sure which. I would mount it flat.

no, there is no good spot on this frame to get it flat and make gps work well. i will see what gives, it is weird. will try to alter its orientation setting again and recalibrate, i am not sure anymore if internal compasses x-y-z axles and this m8q thing axles are aligned at all. it did not make any sense to have yaw180 set if forward arrow is aligned properly and chips seem to be sitting in same way 1st pin wise.

If it’s flat and the arrow is pointing forward you want Orientation 0 (default). I suppose you could use the current location and put a 3D printed angled block under it.

i know! but, when it was set like that, at least 2 axles in real view were changing in opposite ways - internal compasses axles would be decreasing with pitch/roll up and external compass would increase. i literally had to sit and jerk this thing around to understand what happens - did not make any damn sense.

just did some test flight - mount of rubber posts is inferior to previous one. at high speed it did not do alt jump yesterday, but does it today. will look at logs now to compare vibs to see where it is coming from now. it should not have had any.

Servers by jDrones