Poshold or Loiter Issue

Hello for all,

I built a quad in TBS disco style and used a Pixhawk with M8N GPS. The calibration of all sensors, compass, acc, compassmot is ok. The autotune works like a charm. But for the first time, the LOITER and POSHOLD mode just no works. The number of satelites is acceptable, 9> .
I don`t know what is happening , please, check my logs.
Thanks and sorry for my english.

The log link is:

Just looking at your GPS in the logs, there is a problem there.

Even though you do sometimes get enough sats (>6) the hdop is never below 1.5 (needs to be below 1.4)

Even though you can see sky your horizon angle is not enough to get a reliable fix, as sat count is not the sum total of your strength of GPS location.

You should switch to auto modes (Loiter, Position Hold, etc) before arming and check the LED stays green, which you will find it does not from your logs.
You need to wait until the LED stays green when switched before you will get auto modes in flight.

To add my 2 cents, it’s possible that you’ve got some thing on the frame that is interfering with the GPS. FPV equipment is the common one - make sure it’s far from the GPS. I’ve heard a GoPro with the wifi turned on can also had a bad effect I hear although I haven’t noticed that myself.

Thanks for the checks! I tried to takeoff only green led is static.
But i try the tip of takeoff in poshold mode .


Hi Randy !
Thanks for the analysis. I’ll check the FPV gear for interferences.

I put the vibration dampener and the vibration improved much, also try to fly with FPV gear turned off and the POSHOLD persists to fail.
The logs was collected again. Please check my logs again.
2016-11-09 20-52-57.bin (954.2 KB)

Problem Solved !!!

The GPS was the one. Even pointing out the correct location, the problem was in it.
To solve this, i put the M8N Marco configuration.

Thanks for the help.

Excellent news, glad it’s sorted!

Hi renatux. Could you send the config file to guiseco@gmail.com ? Muito obrigado !

Yes !
See your email, config sent.
you’re welcome !

Hi renatux. Could you send me the config file too? carolina_cecilio@outlook.com
Thanks so much!

Here the link:

Look for your GPS unit.

For How to config:

I’ve got to ask - why should you need to apply the config at all? I am led to believe that AP pushes the GPS config at boot time anyway, so surely if you download your own config, this will just be overwritten by AP?
Unless of course you have set GPS_AUTO_CONFIG = 0 (just spotted this setting in wiki)

Paul, that’s correct. I’ll add that if you have the pre-arm checks enabled (and you should!) it won’t let you arm if any configuration is incorrect and ArduPilot couldn’t fix it.