POS hold works, RTL and WP doesn't


We are using Navio2 together with a quadcopter. After initial setup and tuning, stabilize and position hold modes seem to work fine. However, when put into RTL the copter just hovers at the current position. When attempting to fly a mission loaded via APM Planner, the copter takes off to about half off the specified altitude, then starts declining. It never manages to really start navigating towards waypoints. At one time, it tried to speed up again but ended up flipping over and crashing.

Some recorded logs and more information can be seen in

We’ve tried changing a bunch of RTL settings and also tried restoring the default settings.


I’m working with @Thronics on this. Some additional info:

Today I went through flight modes one at a time to verify them in the recommended order at http://ardupilot.org/copter/docs/flight-modes.html.
Stabilize/Alt Hold/Loiter are all working fine. Here are some screenshots from my dataflash logs:

Desired vs actual alt:

Desired vs actual posX/posY:

Desired vs actual velX/velY:

As can be seen the behaviour in loiter mode is fine. However we can see in those logs that when put into RTL it sets DVelX and DVelY to 0. Is this expected?

Thanks in advance for any help!

This issue was finally resolved by updating our ArduCopter binary from v3.5 to v3.6.