Pos_hold dosn't hold pos, and RTL doesn't RTL

Attached is the log file. At the begining of the flight, the drone was in pos hold, but the wind blew it away, while the drone made no attempts to compensate.

At the end of the mission I shut down my Tx to test the failsafe, and even though I can see in the log that CH5 shows RTL values, the drone stated in auto.

Help, please?

Link to the log file:

Log file missing… . :smiley:

Thanks! Turns out the file was to big. Edited original post, with dropbox link…

Check your ch1 and ch2 trims. FC got around 1460 as a middle point from the receiver and the TRIM is set to 1505. No surprise it starts to fly away…
ch4 seems more or less ok.
However I don’t see the reason for not switching to RTL, but the log is somehow corrupted. If possible please post the .bin log, it is easier to analyze.

1 Like

Your Throttle Failsafe is not enabled.That’s why it didn’t switch to RTL.

PARM, 85595449, FS_THR_ENABLE, 0
PARM, 85595466, FS_THR_VALUE, 975

Set to 1 to enable and check it changes when you switch the radio off in the Failsafe page of Mission Planner,preferably before take off.It can save you a lost copter.

Fence was not enabled either,which is a back up if anything goes wrong with other failsafes.

PARM, 85671940, FENCE_ENABLE, 0
PARM, 85671965, FENCE_TYPE, 7

In fact you had zero failsafes operable.

PARM, 85594902, FS_BATT_ENABLE, 0
PARM, 85594920, FS_BATT_VOLTAGE, 10.5
PARM, 85594938, FS_BATT_MAH, 0
PARM, 85594957, FS_GCS_ENABLE, 0

All of them are there to save your copter from your mistakes.It’s well worth spending a bit of time in the failsafes page of the wiki.It’s saved me a few losses over time,including last weekend with a 960 hexacopter carrying an expensive camera.


Are you using just the internal Pixhawk compass ? If not,and you’re using one in the GPS puck,you need to enable compass as external,to avoid it losing position.

PARM, 85598424, COMPASS_EXTERNAL, 0 - set to 1 if in the GPS puck.

As noted above you have corrupt parameters in the servo settings relating to motor output, unless you are using a different channel for motor output.This means you must be using channels 1,3,4,5,6 and number 7 is relating to motor 2.Which can be explained by the way it’s wired up.So you’d better explain that one.I’d expect motor 2 to be on channel 2 and not 7 unless it’s been re-mapped.

PARM, 85704878, SERVO2_FUNCTION, 0
PARM, 85708805, SERVO7_FUNCTION, 34

Thanks guys!
Eosbandi - the trim was the problem! thanks!
Jagger - its strange that enabling throttle failsafe is required (I did not use throttle failsafe) when the failsafe is implemented in the RC receiver… The pixhawk was not suposed to know a failsafe was initiated at all. i guess that the serial SBUS also reports when the RC Rx enters failsafe mode. anyways, you were right. I also enabled the geofence. Thanks!

Regarding the channels used - I changed motor 2 to be on ch 7 after I discovered that my pixhawk did not output a pwm signal on ch 2. I guess its a hardware bug. I’ll open a different thread regarding this issue.

Yep,that’s hardware.Seen it before and it’s not that uncommon a work round.

As to the failsafe - I can set my Frsky receivers up to perform certain functions but the FC still needs to know what that means.Hence the configurable failsafes.With throttle,battery voltage,current remaining failsafes you’re pretty much covered but putting a fence in as well means it can’t get away from you.

Never use trims on a multirotor.As you now know. :smiley:

Good stuff.Hope it flies right.Don’t forget to get that compass configured correctly.