Populating Gimbal page with values greater than RC CH8

Is there logic that reads the MNT values and does not populate the Gimbal setup page if the value is not 6,7, or 8? MNT values are set to ch9,10,11 but the Gimbal setup page does not populate with those values.
Using 3.5 rc1 and 1.3.44


latest beta mp supports this

Thanks Michael. You, of course, know that the Ardupilot project would not be that same without you? :slight_smile:

1 Like

@mike thanks :slight_smile:

Because I’m new, I need help to set up Gimbal on fix wing.
How/Where can I find the MNT_TYPE value on Mission Planner? I think that’s why I can’t check ‘stabilize’ on the Gimbal menu.

Thanks in advance.

All of the parameters in Mission Planner, which are stored on the Flight Controller, can be manually set using the Config/advance parameter list. The setup pages are a convenience but they too just modify the underliying parameter. The MNT_Type is controlled on the Gimbal Setup page at the top “TYPE” and you would set it to “servo” then you can click on stabilize for the axis you wish. But you can also go directly to the Config/Tuning-Full parameter list and change MNT_Type to the value 1, which means “Servo”.

MNT_TYPE: Mount Type

Mount Type (None, Servo or MAVLink)
Values RebootRequired
Value Meaning
0 None
1 Servo
2 3DR Solo
3 Alexmos Serial
4 SToRM32 MAVLink
5 SToRM32 Serial

the “type” in gimbal camera screen is off and i cant check the stabilized
nor the full parameters list nor advanced parameters are mnt type command.
I cant find it anywhere parameter MNT
why is this happening ?
photo from gimbal camera screen

I would guess that your firmware installation is corrupted. I would reinstall. Format your SD card and reinstall your firmware and see if anything changes.

sorry forgot to mention . I have apm 2.8 ,
Reinstall firmware . but still cant find mnt parametr

Sorry I did not recognize this earlier but I am an arducopter user not Arduplane. I checked with an APM board and Arduplane 3.4.0 and the MNT parameter and the fields on the gimbal page are not available in Arduplane as they are in Arducopter. So there is nothing wrong with your setup, The features are just not available.

mike thank you very much for the information.
One last .
You know if the pixhawck * and ardupilot can control the servo gimbal or brussles gimbal or will I have the same problems with the APM.???

What is your opinion . it’s OK ?

Thank you again very much

I tested Arduplane 3.7.1 with a Pixhawk 2.4.8 and it I was able to select “servo” and check stabilize for all the axis on the gimbal setup page. All the MNT_ parameters exist.