PLS help, Quad pitched right and crashed during RTL descendi


First off, I am new to Quad and Pixhawk and I have just completed my build. Today I went out to try the quad after I had successfully completed Autotune from yesterday and a crash with the same symptom.

During the first flight with 1st battery, no gimbal/camera, the quad came back and landed without a problem as I was testing the RTL midway into the flight. Even when the 1st battery hit the failsafe level, the quad came back as I set it to RTL when batt is low. All in all, the 1st flight with the 1st battery went without any problem. I wasn’t flying over 10m above ground and was flying away for maybe about 1 football (soccer) pitch length. No problem there.

Then I switched battery, put on the gimbal and camera and went up. This time, I went up to about ~20m around the same field length. As I was flying around, I decided to try the RTL that I set it to CH8 switch for emergency. The quad was the furthest away, both height and distance from where I was standing, maybe around 1.5 football pitch length and 20m up. I flicked the switch (which was calibrated and confirmed working when the quad was not armed by checking the computer screen via tele) and the quad slowly came around, nothing special there. Until it was right above the take-off spot and was descending, then suddenly it pitched to the right quite sharply. I do not know exactly if it was “sharply” or not, but from what I saw, it was quite sharp and quick. I tried to correct it but the quad did not respond to my command. Luckily it crashed in the woods next to the field, nobody was injured, no 3rd party damage, the quad had a few tiny broken pieces, nothing serious. But I am quite baffled why this happened.

It’s actually not the first time the quad pitched sharply to the right, ignoring my input, and crashed. It happened yesterday after I completed the Autotune and was on 2nd battery, flying around on AltHold, then the quad did exactly the samething. I thought it was the big transformer I was flying by that caused the flyaway, but today I was at an open field with nothing possible to interfere.

The quad did not have a log from yesterday crash, but I’ve got it from today. Tried to look at it but I am quite new, so I’m quite lost of what to look for.

Any help or guidance is highly appreciated.

*correction, the quad rolled to the right … I was using pitch.