Please improve the uninstall robusstness

Hello, I just write this article for suggestion,
this is not the request on solving problem.

I turned on my mission planner after 1 year from installation, because I was recently busy with works.

I tried to update it but error message continuously appears. I remember that was related to hash check.
first, there was error message about the parameters and then the program automatically downloaded update files, and after that there was error message about hash check.
I couldn’t capture the screen or error message, sorry.

I was using iPhone hotspot on republic of korea, so I guess it could be the reason of problem.(network port or firewall problem…?)

so, I tried to uninstall the mission planner. and it didnt uninstalled for very very long time.
I had to wait with my laptop opened and unused.
for long time I thought the uninstallation process was stopped(stucked)

all this process consumed my time so I suggest reviewing on the installation and uninstallation process, to development team.

this is only suggestion, and not for the request.
I feel mission planner and ardupilot is great software.