PLease HELP with PIXHAWK 2.1

I really need some HELP, PLEASE…

Its regarding PIXHAWK 2.1 (THE CUBE), I mounted the cube on a frame had some successful flights as well, but since morning it was giving various errors and i couldn’t find any other solution then using FORCE PX4 BOOTLOADER which also got interrupted by some error and it stopped in between.

Now i cant connect it at all, i tried different cables, com ports, baud rates,formatted sd card,tried to change firmware but nothing happened.

Before this happened the GPS was showing RGB lights which it is not showing now and only red led blinks of safety switch, and below the cube only orange light is showing, one is solid and other is blinking.

I am in serious need of help right now, it is my final year project and only few days are remaining.

Please help please please…

Email id:

What about SD-card? inserted? Try another one
I’m not the expert for electronics but I had forgotten to insert sd-card and was not able to connect via USB and the safety switch was blinking. Hope you will find a not so serious problem.

i checked the card was inserted, The other sd card should be blank or it should have something on it?

SD-card blank formated FAT32 max 8GB


OMG i cant believe it worked!!!

Thank you so much!!!

You are a savior.

by the way I used a 2gb card, hope that’s enough.

fortunately not such a big issue - glad to give you this hint. :grin:
2GB is ok more important is a fast (class10) card. With standard log settings you will need about 1,5 MB per minute.

Sir I am in facing problem;

I have connected pixhawk cube, via supplied power module, in order to get the voltage telemetry I did following:
In initial setup section, > battery monitor>

Monitor: voltage and current (also tried Battery volts)
Sensor:(3DR power module/other)
APM Ver: cube or pixhawk

I am getting 0 At measured battery voltage
And also 0 at flight data screen.

Kindly help
Thank you