Please help Pixhawk-4 won't calibrate

All,

I have tried everything I could find online to get the system to calibrate. With external compass and GPS without QGroundControl, Mission Planner etc. With power with USB every possible combination possible, Tried it on a PC on a MAC… I’ve also re-flashed it several times. I can make a video if that helps. Nothing works. Radio hooks up fine everything else is OK, I really need to get this working Putting it on a Flamewheel 450.

Help!!!

I’d ask in a firmware forum. You may get more hits there. The ground station doesn’t really do the calibration, the vehicle firmware does.

Trying to understand your issue first. So, you cant get calibration (what part of calibiration? Radio, orientation etc.) completed and the external GPS doesn’t work? Is that what the issue is?

What Flight controller are you using?

Explain how everything is wired to FC?

Good day, are you using the last firmware 4.0.3?
what kind of gps module are you using?

Are you saying when ardu tells you to leave quad up right, then put on left side, then right, put nose down, then on the rear then upside down on it’s back?

my friend and I are not having good flight with that 4.0.3 firmware. We went back to what we first had installed and have not had any issues.

No as in the original post radio works fine using a Taranis X7 everything is fine with the radio. The sensors won’t calibrate. It dose’t tell me to put face down face up etc. It just sits there and does nothing. I gave it to one of my students to try on his computer. We have a bunch of these and this is the only one that has the issue. I’ll report back in the future on the outcome with the student. And yes I have the current version of the software.

bump, same problem
thanks

@yaboyjb311 can you explain what your problem is? what flight controller, which firmware version, a quick summary of your wiring, and finally steps to reproduce?

i seemed to have the wrong firmware downloaded. just as we thought. i am now facing the battle of trying to set up my 4glte raspberry pi pixhawk. i have set up everything and am connected to the drone and am able to sent commands to the drone via mavproxy. but am getting the fallowing:
Servo volt 1.1
AP: Prearm: throttle below failsafe
AP: PreArm: compass not healthy
AP: Prearm: compass 0 not found
AP:Prearm: RAdio Failsafe on

Check parameter value for the radio failse, about compass not healthy seems the offset its too high… so check how you have install your compass module and keep it far from cables… metal and antennas, perform a new calibration far from magnetic sources

yes compass is up raised away from everything. now i have a new computer and have been trying to get everything switched over and i did finally get the raspberry pi connected via udp port baudrate of 111000 connected over 4glte. i am now trying to calibrate the esc and the rest of the manditory things needed. and now im having all my escs calibrate and then there is 1 motor that does not it just keeps beeping and jerking back and forth. my plan is to use a joystick to fly. i have my joystick all set up but it doesnt seem to control anything? so many things seem to just not add up?

this the error i get when i try to plug my pixhawk back in after i attempt to plug it back in via usb.

should i just say screw usb now that i have it figured out over udp?

ArduPilot 4.0 is not able to calibrate multiple compasses at once.
Are you trying to do that? If yes, update to Ardupilot 4.1.x