Planner crashes when loading a Log file

APM PLanner 2 V2.0.28-rc1-DEV. When loading some load files it will get to ~65% or so and then the App will close. This seems fairly recent and I’m not sure what the common deneomitor is for it to happen. Larger logs with batch logging possibly. Also, showing ESC telemetry parameters would be nice.

I realize APM Planner isn’t actively updated but perhaps it will get some attention? I really like it for some log analysis tasks.

You could try the new release candidate - should be better :slight_smile:

Is there a Windows Installer?

Sorry - not at the moment :unamused:. But I hope in the near future…

Confirming that I ran into this issue today. I’ve been using 2.0.27-rc1 for a while. Today I tried loading logs with INS_LOG_BAT_MASK=7 and APMPlanner crashes on those logs only.

Other logs with INS_LOG_BAT_MASK=0 are opening fine.

I came across this thread and then installed v2.0.28-rc1 and the same issue persists. Like Dave mentioned, it seems to have something to do with batch logging enabled.

Even I like to use it for certain log analysis tasks, however I’m also on Windows so I’m unable to get v2.0.29-rc1 running. Is there any other way?