Plane tracks wp line with 10 deg left bank angle


im flying a 3DR aero-m that with the hope to use for ag field mapping. Ive had two of them one was twisted up pretty bad out of the box and flew as bad as it looked. I tried to realign everything and got if flying much nicer but gave up going any further with it when I noticed the tailboom was jammed into the fuse pod off to one side. The plane flew with a -10deg bank all the time in auto mode I blamed the tail. 3DR sent a new aero-m as a replacement this one is nice and straight the tail, wing, horiz stab, and fin all are square.

The new aero-m still tracks wp lines in a -10 to -12 deg bank as a result it turns harder to the right than it does to the left and If I tried taking photos they would be junk due to the high bank angle.

When the plane is on the ground and I place a bubble level along the wing saddle and watch mission planner both the bubble level and indicated roll angle indicate zero.

I trimmed the plane straight line tracking (naked eye)

what steps do i need to follow in this case so that any roll, pitch and yaw trims either mechanical (adju clevis position) or digital (radio trim) are carried over so the plane tracks level when flying level. there was no wind during this test either.


Sounds like your yaw (rudder) trim is way off. Check for any warps. Look at yacc from the telemetry log. Adjust the rudder until it is close to 0 during straight and level flight.

After that you may also need some Yaw parameter tuning. What aircraft do you have?


You are right! Rudder trim needs to be way off for it to fly straight.

Its a 1900 skywalker that 3DR uses as the “Aero-M”

I also have the Volantex ranger ex both planes suffer from yaw induced by power. If you trim them perfect for glide and the plane is built square you will notice that all flight surfaces are near mechanical zero when the plane flies straight and level. Adding power induces a yaw and in the case of the ranger adding motor offset does not reduce this tendency by any reasonable amount. I found that running a pusher prop does reduce the issue by about 90% (Motor offset and pusher prop test were not done on the skywalker)

Instead I just ran in a ton of rudder trim until the plane tracked well on the mission planner screen, nice and level, and holding a compass heading without drifting off.

I then used Trim_auto parameter by setting it to 1 and then sending the radio trims over to the autopilot. (this is really the necessary step required to solve my problems) once the auto pilot learned the rudder’s default trim position the plane then flew flat and level as it no longer had to compensate for the yaw issue.


That solution works until you try to switch to Manual mode, then it’s very hard to fly straight.
Interesting that the pusher prop helped. I bought one to test for this purpose, but haven’t tried it yet. I suspect that yaw is caused by spiraling slipstream on the vertical stabilizer rather than just torque.
There are several other threads on this issue on this forum. It’s a real problem with Skywalkers.