Servers by jDrones

Plane powered up after weeks being off, all RCx_TRIM values changed?


(Graham D) #1

Just had the weirdest thing. Took our plane (Nimbus 1800 VTOL) for a flight after a few weeks of no flying. Plane had flown fine the last time and hadn’t even been booted up since then.

Armed the plane to do a quick test hover, which was fine, then tried to disarm - and it would not!
Eventually was able to disarm with Mission Planner, tried to arm again and got an error that the trim values were lower than the minimum values.

So I checked, and all 16 channels trim values were set to a value of 874! The original values for all 16 channels was 1500.

How on earth does that happen? First time it’s booted in weeks and somehow all the trim values change?

Or is this just another idiosyncrasy of Ardupilot that we must accept?


(David Ingraham) #2

This is curious. Any chance you have TRIM_AUTO Enabled and throttle Failsafe disabled? I can imagine that causing it to save trims at bad values like that. However, it should never save trims if the value is lower than the RCX_MIN value.


(Graham D) #3

TRIM_AUTO is 0 and throttle Failsafe is 1.
It’s VERY strange, all I did was connect with the usual RFD900 and then fly, the first sign of something amiss was the inability to disarm, arming worked fine the first time but not thereafter. So this must of happened after the first arming? I’m going through the logs to see if anything stands out.


(Graham D) #4

Values from TLOG, channels 9-16 are at 874:
Trim_change1

Values set currently:
Trim_change3

So where does the 874 come from?