Plane performs unwanted climb on RTL - only if far away from home location

Hi guys,

we’ve done some BVLOS flights with a Foxtech Nimbus VTOL (ArduPlane V4.1.0dev (c6f12e51)) last week using terrain data loaded on the MicroSD of the Pixhawk.

Terrain following worked very well during AUTO.

On this particular flight, we had a 180° turn at a waypoint, this caused the plane to roll 75° (way more than roll limit) and lose some altitude. The aircraft recovered and went back on its flight path. As there was another waypoint with a 180° turn, we decided to stop the mission and perform an RTL.

As soon as RTL was triggered though, the aircraft climbed from 80m AGL to 117m AGL and stayed on that altitude until it returned home (following terrain again from there on).

The RTL altitude is set to -1, so it should stay at the current altitude.

Any ideas what could have caused this? We’re aware it’s difficult since this is Foxtech’s dev firmware, working on flashing Plane 4.0 to all Nimbuses soon.




Hi Oliver,
I have been talking to the Ardupilot team, since I also identified some issues (differences) with the Foxtech 4.1.0 dev firmware (Is actually not even the current 4.1.0). They are making some progress and hope to get a copy of the source code soon to rid these bugs. The good news for the problems I have found so far is they can be solved by a parameter change or were deliberately removed from stable version for safety. I would be interested to hear how you got on - Maybe an “Issues with Foxtech Firmware” thread is needed.