Plane goes to RTL mode when commanded to AUTO

Dear All,
After a couple of successful flights, i found my other aircraft of the same configuration was going to RTL mode when i trigger AUTO mode using handheld RC transmitter and the GCS. This is the only aircraft which does this peculiar action. I have already tried setting up the flight modes again and again. All other modes are getting activated on appropriate commands from the GCS. Please find the attached logs of the bench testing done this evening. FYI, I did some engine runs on the ground to tune my engine for performance. I use Pixhawk, AP3.8.2 and RFD900.
Thanks in advance.
Download link:

A .bin file from the Pixhawk would be more helpful than the .tlog files.

1 Like

Hi buddy does it have a mission with way points loaded ?

1 Like

Hello Colin,
The issue was solved once I gave some mission to the Autopilot. I never had
this issue with other boards which are new and didn’t have a mission in
them. Strange but worked.
Thanks and cheers.

That’s why i asked did it have a mission loaded
its apart of safety features :slight_smile: