Plane crazy pitching in any auto mode - Video

dear experts,
i’m stuck with this. whenever i switch to an auto mode - preferably to autotune the plane goes either straight up or bottom down and holds that position until stall or crash. no interest in leveling. when i try to hold the plane around the horizon (which i guess is not the idea of autotune) i can do it for a little while like balancing on a ball but once either too much up or down the plane gets “suck” into either direction and the FC is working hard to hold it there. no input effect to get her out!

i’ve done many test flights with all sorts of different parameter settings - from low to high, recalibrated multiple times and and and. on the bench it all looks good except when i switch to any auto mode the servos go a bit crazy - then quiet, then crazy again… just weird. i’ve read on crazy servos on the bench and some guys claim that once the plane is airborne this is gone. it seems to be like that for me as well otherwise i could not hold her for a few seconds.

board orientation is yaw 270 which seems to work according to mission planner AH. however - that would be the most logical thing to me being wrong and i 've experienced some strange required settings in that area in iNav and Betaflight - but the AH simulation looks fine.

I’m using a Matek F405-Wing with the latest firmware. before the whole setup with board, plane etc. was flown with iNav without any issues. so i rule hardware problems out. the plane is also nicely balanced and the controls physically limited and adjusted - just the way it shold be - all fine… until flashing ArduPilot…

after more than 10 test flights the plane has never flown in auto mode. it instantly pulls up or down when any auto mode is engaged!

maybe the video helps to explain…

thanks upfront for any advice that could solve the mistery!!!

these are the current settings of the parameters i think are relevant to this issue and that i’ve played around with.

Bank to 25
Pitch Max to 35
Pitch Min to –20
Stick_mixing to 2
(All P,I,D set to 1,0,0 wherever possible)
RLL2SRV_P to 1
RLL2SRV_IMAX to 3000
STEER2SRV_D to 0.08
Stall_Prevention to 1

Why have you set all PIDs to 1;0;0?

Why not leave them as default? Default usually flies pretty well. So I and D are O? That may be an issue.

thanks for your input!
i’ve started off with default and tried many different settings with no luck. i’ve read on the ardu doc that a good way to start with 1,0,0 even though it does not let me go all the way down to 0 on some parameters. tried a bunch of configurations but i’m always happy to test any suggested combination of PID! Thanks

Is your elevator servo moving the right direction when stabilise mode is enabled on the ground and you tilt the aircraft by hand up and down? (See here:

You should get that going the right direction in stabilise first, and then change your radio or the radio config page to get manual control operating the right way.

Glen, thank you for your input. Yes the servos are moving the correct way kind of… the direction is initially ok but then they all go crazy on the ground after a few seconds. even if i fly in FBWA mode i can hold the plane for a few seconds with the stab functioning until it gets either sucked up or down. i don’t get the typical oszillation issues or other common mistakes. it all seems to work fine except that the plane thinks forward is down or up as if the pitch was 90degree off - everything else works just fine.

are there any known issues that the AI in MissionPlanner is not reliable??? Am I correct that the board orientation is ok when the AI moves the right way? I once had an issues in iNav where the board was mounted 90degrees off - but in order to get it working i had to change pitch 90, roll 180 and yaw 270 - but the grapic in iNav is much better than just this simple AI in MP.

Could you post a .bin file from the flight controller so we can see your settings and the planes response to input.

thank you for your support. bin file? i have a param file with the settings. i hope that’s what you mean. T-28 round 3 Setup.param (21.9 KB)

I guess log files would help. did not record them so far. if params don’t bring any revelation then i could try to generate some log files. thank you again!

Have a look here for log download information.

Just maidened my plane and had the same exact errors. Nose pitches up or down with no way to recover. I have logs of my trying to go to AUTOTUNE/LOITER/FBWA. I’m wondering if anyone else has had this issue and has been able to solve it. I’ll keep looking for a fix on this forum to hopefully fly tomorrow. :crossed_fingers: