Plane 4.4 release

Looking at the error message seems like this change may be at fault AP_GPS: improve support for uBlox-M10 · ArduPilot/ardupilot@b12cd48 · GitHub
when removed following lines

            // none of the 9 series support the SOL message
            _unconfigured_messages &= ~CONFIG_RATE_SOL;

Any chance to see the speedybee f4 wing supported on the next beta ? I have no clue if several dependencies on 4.5 code but this board is pretty nice and for the first time as affordable as it used to be pre Covid. Looks it’s becoming popular based on YouTube reviews.
For now it’s supported only in 4.5 and I don’t fell confident enough in my skills to fly on a nightly release :smile:
Many thanks

I’ve just released plane 4.4.0beta2. The changes since the first beta are:

  • added SpeedyBeeF405WING, JSB100 and FoxeerH743
  • added LOG_DISARMED=3 support and LOG_DARM_RATEMAX
  • fixed error handling for being out of memory in EKF initialisation
  • fixed a bug in RC input handling on the IOMCU
  • fixed a bug handling ICE engine start after altitude reached
  • adjust EKF3 accel bias process noise for greater robustness
  • fixed an EKF3 bug in accel bias calculations
  • cope with compassmot impacting GSF yaw numerical stability
  • fixed an AUTOTUNE/QAUTOTUNE bug in yaw tuning
  • support INA228 and INA238 I2C battery monitors
  • always log rate PID slew limiters even when slew limit is zero
  • added MambaF4050v2 for new IMU, bdshot and DMA on UART1
  • update for FoxeerH743v1 GA release
  • reduced IMU init speed on MatekH743
  • move LED serial processing to its own thread
  • fixed parameter documentation for BRD_SAFETYOPTION
  • don’t reject airspeed using EKF innovation if dead-reckoning
  • fixed USB pass-thru on 2nd USB endpoint

Thanks to everyone who is testing the 4.4beta!


i flew beta 4.4.0beta2 today with two fixed wing aircraft (mateksys H743-SLIM, mateksys F405 wing in FBWA,CRUISE,AUTO,TAKEOFF) without any problems. A Speedybee F405 wing on the other hand (still on the workbench) did not recognize either a MS4525D0 or an SDP33 airspeedsensor. The latter type works fine on both mentioned aircrafts. It could of course also be a hardeware defect on my Speedybee F405 wing.


1 Like

I just see on the WIKI page that the SDP33 is not implemented on the Speedybee F405 Wing for memory reasons. I could try for a long time. But a MS4525 should work according to the list, however.


SpeedyBee F405 WING APP Fixed Wing Flight Controller Could become one of the most popular flight controllers, especially with that price 47€ against a 148€ Matek, the difference is just to immense, please fully implement this for everybody.

1 Like

I’m afraid that the price difference will also have something to do with quality differences. But I think we should share the Speedybee Wing experience in its own thread: SpeedyBee F405 Wing Firmware

With the beta2 I flew this morning with further aircraft types to my complete satisfaction. Thanks to the developers.


1 Like

@Rolf on each release you can see the enabled/disabled features like this:
you can see MS4525 is enabled, SPD3X is not enabled.
You can also use the custom build server to enable whichever features you prefer

1 Like

Hi Rolf, did you fly with the Speedybee? I’m still waiting for it to arrive, as soon as I got it I will put it on the Ar wing pro and I will share my experience in the Speedybee threat. Happy flying Orson

Hello, I saw that there is support for esp32 but I can’t find the mission planner firmware: c

edit: is this the only way for now?

1 Like

I was home the other month and was trying to fly a bunch of stuff. I mainly flew quads as I wanted to get proficient with those, but I took 2 planes home that had been previously crashed and fixed. both planes had an initial autotune done ages ago around arduplane 3.7 so they weren’t terribly untuned but not perfect plus I am such a novice when it come to arduplane. I think I can set on up ok but flying is another ball game. One was a Zohd Nano talon the original frame they released not the evo it had a pixracer in it and the second was a nimbus 1800 that banggood mistakenly sent me years ago and had crashed once due to poor airspeed sensor location, it was running a original pixhawk 1 from mrobotics. I was trying to learn the takeoff mode but I was never able to get it to work I kept getting bad launch or some message I cannot recall. In an effort to get things in the air the common chain of events happened on both airframes when it came to crashes. During my walk through on the nimbus I noticed the pitch stick was backwards in manual mode but worked fine in fbwa with the right reactions given airplane attitude. I was using some remote that I could not get into the user interface and reverse it (I think its a skydroid m12L??, it was a sample they sent me) I just decided that my brain would be OK remembering pitch was backwards. Tried takeoff mode with a bungee a couple times those failed due to my lack of use with the bungee and technique. So I decided to try takeoff running with it which again failed. Then I tried to just run with it with the remote and boom got it to takeoff but my brain failed to remember the reversed pitch so it climbed straight up sat on its tail quite well and then mortal combat button mashing self here panicked and it went straight down into the ground for prosperity that log is here and a earlier takeoff mode failure here.

Now the nano talon I also tried takeoff mode but could not get it to work either. So I just ran with the remote and threw it a few times and finally it flew after first hitting the ground then a slight dike in the field and that little dike was just enough to get it off the ground. it was very sluggish on turns turning one way much better than the other I flew around a bit then it seaminly decided gravity was stronger than its will to fly and hit the ground. I am very poor at log analysis so I was wondering if anyone could see why it did that in the log here. I was also wondering why my takeoff mode was failing here. Both the flight controllers survived and will live another day the pixracer as a ap_periph hahaha they are just getting to taxed with all the new stuff plus they can’t run most of the new scripting features!!! All these flights were conducted under the 4.4.0 beta1. I have always been hesitant with planes because you have to know what you are doing as there is no let off the sticks and hover plus I like to test in large open areas which where I live I don’t really have but home at the ranch I have massive amounts of open area to test its just a 10 hour drive. That brings me back to the chain of events that lead to the crashes which time constraint was one of them and its very simple to get in that mindset just like in crewed aviation there is a chain of events that always leads to accidents. Risk is a very interesting topic when it comes to UAS operations compared to crewed aviation. thanks to all the devs for the great flight system as you see from the logs it can fly some pretty untuned aircraft quite well.

I have set these two parameters on the Nano Talon Evo:

In your case (TKOFF_THR_MINSPD = 4), the Nano Talon must first reach 4 m/sec * 3.6 = 14.4 km/h before the motor starts running. How is that supposed to work? You’ll have to throw very hard for it to a) reach speed and b) have enough lift by then.

I jerk the aircraft briefly, the motor starts to run and I throw the Nano Talon. With this, TakeOff works perfectly.

I was just using the plane documentation for automatic takeoff which for hand launching suggest that 4 m/s target. So that is more than likely the case in both of these as I had both setup for hand launching via the docs.
" The TKOFF_THR_MINSPD parameter is a minimum ground speed (as measured by the GPS) before the motor starts. This is an additional safety measure to ensure the aircraft is out of your hand before the motor starts. A value of 4m/s is recommended for a hand launch."

@406FPV it is very plane dependent. Many planes need to throttle up before you throw, so a MINSPD of 0 is needed. Others can wait on throttle till after it has speed.
@hwurzburg I think we should adjust those auto-takeoff docs to not imply that all hand launch planes need a TKOFF_THR_MINSPD. I certainly don’t set a MINSPD on my small planes. A key factor is how the prop is placed relative to the pilots hand position which determines the risk of cutting yourself with the prop.

@tridge…expanded and added some clarifications expand tkoff_ parameters explanations by Hwurzburg · Pull Request #5213 · ArduPilot/ardupilot_wiki · GitHub
will merge tomorrow…

we try to avoid this

@hwurzburg understandable but I threw the Jesus out of those two airplanes and never got anything because I couldn’t hit 4 m/s which is very fast for a hand launch. For an airplane hand launched I doubt many will ever reach that speed so should it also be recommended to lower that value. I see you say 4 m/s is a good starting point but I beg to differ no one will hit that and will constantly get bad takeoff.

that is surprising…4 m/s is only 8.9 mph…I can throw a mini talon that fast with a slow throw… look
iing at your log you have the accel set at 15m/s/s which is 1.7G…the gnd spd does not even come into consideration until you have jerked it that much on the hand throw…maybe thats your issue

no looks like you exceeded that but get a bad launch immediately…will look into what causes that

going off the wiki for hand launching it states that this is a value good for most aircraft unless I am reading it wrong?
" The TKOFF_THR_MINACC parameter controls the minimum forward acceleration of the aircraft before the throttle will engage. The forward acceleration comes from the throwing action of your arm as you launch the aircraft. You need to set this value high enough that the motor won’t start automatically when you are carrying the aircraft normally, but low enough that you can reliably trigger the acceleration with a normal throwing action. A value of around 15 m/s/s is good for most aircraft."

okay looking at the log, you tossed it and it pitched up almost 50degs as it left you hand and that exceeds the angle limits to allow motor to start…that is why the motors did not spool up…not the param values

1 Like

I was throwing it at a upward angle. So is the better just to toss at a normal angle or straight out in front of you. I have a lot to learn when it comes to fixed wing.