Plane 4.3.4 on omnibus f4prov3 RTL height in mission?

Hi all. When I try to plan an autonomous mission with last mission point as RTL, the altitude introduced and “relative” selected does not stick after writing the mission to memory. In parameters, the altitude is default 100 meters.
Re-reading the saved mission from fc, RTL altitude is zero, “relative” changes back to “absolute”.
Any thoughts?

I think the LOITER_TURNS command needs a location. (lat/long) I just tried it in the sim and as long as I gave it a location for the loiter it seemed to work fine and I didn’t have issues with the RTL altitude.

Thanks, I’ll try to get a GPS lock and see what’s…

Without a GPS lock, some time ago, I could made any mission and upload it to the fc.
Now, this is what it happens.
I can write the parameters for rtl height, then upload it to the fc, but when I read it back, it changes. See attached pictures.

I see you’re manually setting an altitude. Try without that. The RTL will fly back and loiter at whatever you’ve set ATL_HOLD_RTL.

It was as you describing, it did RTL and almost hit the ground. I had to re-take command and switch out to FBWA to avoid crash…

Usually, I could make different types of missions, depending where I fly and land, with different obstacle heights around. And just writing the needed one, with different RTL height.
Not flown recently, updated the arduplane and mission Planner a few days ago, now this issue emerged…

What have you got ALT_HOLD_RTL set to? Remember that value is in cm, not m.

Mission Planner just updated versions yesterday. Maybe try and update that again.

RTL is set to 10000 cm (=100 meters) in full parameters list

Can you post the .bin from that flight?

Unfortunately can’t post the log, but the original question remains. Why, in mission planning tab, when RTL altitude is manually set / saved DOES NOT stick.?