Plane 4.2 stable release

Automatic Landing too short:
What do I have to change when my my automatic landing approaches are too short. Slope seems to be OK, but Tecs.hdem seems to be unreasonable during landing sequence (seems to me, tecs controller wants to go steeper than required to meet the targeted landing point). Please find the logs attached here: Logs_AutoLand
Thanks for looking at it.
Cheers

hi @tridge
i was trying to connect RFD 900x modem On CUAV V5+ running on AP 4.2.2
RFD modem connected on Telemetry 1 port with below setting
SERIAL1_BAUDRATE = 115
SERIAL1_PROTOCOL = 2
my RFD radio setting as below :


Screenshot (136)

when i try to connect with mission planner at initial stage its getting data for just 2 sec and after that it wont get any data as link quality also keep decreasing up to 9% but still no luck connecting.
but as i can see the radio LED’s both radios working correctly. Finally No luck to get connection.

but same RFD 900X modem i had tried with Arducopter 4.2.3 on CUAV Nora+ with same setting and same wiring, its connecting and reading the autopilot data (only thing is its also went up to 20% signal quality after getting connection its start reading and while its keep increasing signal quality up to 98% after some time ).

i have taken video of both Arduplane and Arducopter how its reacting while connecting to mission planner RFD 900x modem connecting issue - Google Drive

I also tried this setting on Flight controller that BRD _SER1_RTS,CTS parameter to 0
and tried SERIAL1_PROTOCOL = 1 (Mavlink1) no luck.

please kindly look into this issue and give me solution.

I have flown VTOl today and need Little tuning to get better flying.

Any how i have noticed 3 issue :

1.Land disarm delay default timer was 20 sec …but this one i have reduced to 5 sec but it doesn’t work as expected.
Either VTOL land by QRTL or QLAND the land disarm delay is doesn’t work at 5 sec…its works after 16sec only disarmed.
I have configured ARM_Rudder = 2( can arm or disarm)
It only disarmed when in QHOVER mode and not in QRTL or QLAND by RC stick.

2.when i flown in fixed wing mode loiter or Guided mode trying to fly at some altitude like from 100m to 200m.
It was climbed upto 210m and then slowly coming down to 195m and later it settled to 200m.how to reduce this overshoot in altitude and get stop in desired altitude at first attempt.

3.loiter radius was set to 200m but when it flown in loiter mode i seen that in HUD screen it was around 260m below mode indication.

Note: WP_radius was set at 60m …it may be added up with WP _ Radius?

I’m trying to trace the PID control changes between Plane 4.0.x and 4.2.2. It is clear that the fixed wing plane PID changes occurred during 4.1.x and I have found the conversion calculator for that.

However, it appears that the quad plane PID control also changed between 4.0.x and 4.2.2, but I can’t determine when or how to convert between 4.0.x and 4.2.x.

Edit: this is assuming the quad PID control changed, as there are significant changes to the QuadPlane PID value ranges that put my 4.0.9 values out range for 4.2.2…

Hi Rolf,
how did you build the version for F405-WING with LUA?
If it’s done manually in hwdef.dat - could you post the file here?
I’ve a Sailplane only with GPS (no Compass or other external sensors) where there should be enough free memory for lua-interpreter.

Hi Willy,

I hope not inadvertently given the impression of being able to run LUA scripts on an F405. I also have LUA scripts running only on the F765 and H743. Hope I didn’t make a typo somewhere.

Rolf

It seems the developers are working on a minimized configuration especially for 1MB FCs. So I had the impression it’s still available.
Building a small Sailplane version only with GPS and soaring leaves 285072 Bytes blank - that should be enough for scripting :o)

BUILD SUMMARY
Build directory: /mnt/volume_nyc3_01/custom/base/tmp/plane:MatekF405-Wing:71828602e5eda0c68743352c1e8edd8af6a542a5:7298a57836b151b2f2fb6c9321cd9eaa/MatekF405-Wing
Target Text (B) Data (B) BSS (B) Total Flash Used (B) Free Flash (B)
bin/arduplane 697168 788 130368 697956 285072

it might be enough flash, but you won’t have enough ram on a F405. Lua is memory hungry

Thank you for the clarification @tridge , that I haven’t been aware of. So Scripting on F405 will never be possible, if I understood right.

So my PR Relocate mission 0.1 by WillyZehnder · Pull Request #21363 · ArduPilot/ardupilot · GitHub for relocating a mission still makes sense.