Plane 4.2 beta release

I have released Plane 4.2.0beta1. This is a major release with a lot of changes. We expect at least 4 weeks of beta testing and several beta updates before 4.2.0 final is

Changes include:

  • EKF startup messages reduced
  • LORD Microstrain CX5/GX5 external AHRS support
  • Auto mode supports up to 100 DO_JUMP commands on high memory boards
  • Auto support for NAV_SCRIPT_TIME commands (Lua within Auto)
  • aerobatic scripting from any mode via RC switches
  • new boards AirLink, BeastF7v2, BeastH7v2, JHEMCU GSF405A, KakuteH7, KakuteH7Mini, MambaF405US-I2C, MatekF405-TE, ModalAI fc-v1, PixC4-Jetson, Pixhawk5X, QioTekZealotH743, RPI-Zero2W, SPRacingH7 Extreme, Swan-K1
  • Parachute option to leave servo in open position (see CHUTE_OPTIONS parameter)
  • Parachute released arming check added
  • Pre-arm check of IMU heater temp
  • Pre-arm check of rangefinder health
  • Pre-arm check of throttle position skipped if PILOT_THR_BHV is “Feedback from mid stick”
  • ADIS16470, ADIS16507 and BMI270 IMU support
  • AK09918 compass support
  • Battery monitor supports voltage offset (see BATTx_VLT_OFFSET)
  • Benewake TFMiniPlus I2C address defaults correctly
  • Buzzer can be connected to any PWM on any board
  • Compass calibration (in-flight) uses GSF for better accuracy
  • CRSFv3 support, CSRF telemetry link reports link quality in RSSI
  • Cybot D1 Lidar support
  • DroneCan (aka UAVCAN) battery monitors support scaling (see BATTx_CURR_MULT)
  • DroneCan (aka UAVCAN) GPS-for-yaw support
  • Electronic Fuel Injection support incl Lutan EFI
  • FETtecOneWire resyncs if EMI causes lost bytes
  • IMU heater params renamed to BRD_HEAT_xxx
  • Landing gear enable parameter added (see LGR_ENABLE)
  • Lightware SF40C ver 0.9 support removed (ver 1.0 and higher still supported)
  • Maxbotix serial sonar driver support RNGFNDx_SCALING parameter to support for varieties of sensor
  • MPPT solar charge controller support
  • MTK GPS driver removed
  • Optical flow in-flight calibration
  • Ping200x ADSB support
  • Proximity sensor min and max range (see PRX_MIN, PRX_MAX)
  • QSPI external flash support
  • uLanding (aka USD1) radar provides average of last few samples
  • Unicore NMEA GPS support for yaw and 3D velocity
  • Board ID sent in AUTOPILOT_VERSION mavlink message
  • DO_SET_CAM_TRIG_DIST supports instantly triggering camera
  • DJI FPV OSD multi screen and stats support
  • GPIO pins configured by setting SERVOx_FUNCTION to -1 (also see SERVO_GPIO_MASK. BRD_PWM_COUNT removed)
  • GPIO pin support on main outputs on boards with IOMCU
  • GyroFlow logging (see LOG_BITMASK’s “VideoStabilization” option)
  • Firmware version logged in VER message
  • SD card format via MAVLink
  • Serial port option to disable changes to stream rate (see SERIALx_OPTIONS)
  • VIBE logging units to m/s/s
  • BLHeli passthrough reliability improvements
  • Compass learning (inflight) fixed to ignore unused compasses (e.g. those with COMPASS_USE = 0)
  • EKF optical flow terrain alt reset fixed (large changes in rangefinder alt might never be fused)
  • EKF resets due to bad IMU data occur at most once per second
  • GPIO pin fix on CubeOrange, F4BY, mRoControlZeroF7, R9Pilot
  • MAVlink2 serial ports always send MAVLink2 messages (previously waited until other side sent MAVLink2)
  • Omnibusf4pro bi-directional dshot fix
  • Real-Time-Clock (RTC) oldest possible date updated to Jan-2022

Happy flying!


Works fine (FBWA and AUTOMATIC, F405 Wing, ASW28) without any problems. Thanks to all developers

I think there is a problem with geofence breach. I’ve reported it here (with log).

I’ve just released plane 4.2.0beta2. This is the 2nd beta of the 4.2.0 major release. This beta should be close to the final 4.2.0 release.

  • fixed EKF3 constrain bug
  • added quadplane ship landing support
  • added Q_LAND_ALTCHG to adjust landing detection sensitivity
  • fixed a bug in terrain home compensation
  • changed quaplane POSITION1 landing controller to use jerk and accel limiting
  • fixed default gain for weathervaning on quadplanes
  • fixed health check of airspeed sensor for dual sensors
  • fixed arming check on servos for GPIO outputs
  • disable stick mixing when RC input is unavailable
  • fixed stick mixing during GCS failsafe
  • disallow mavlink disarm while flying
  • adjust frequency selection for DShot
  • fixed logging bug for MCU voltage
  • added BeastH7v2 support
  • improvement to AC_WPNav for quadplane waypoint control
  • simplify RC failsafe messages sent to GCS

Happy flying!

1 Like

Hi, this is my 1st post on this forum and would like to thank you for the hard work on arduplane. I started with Arduplane around newyear 2021. Arduplane was the only OS that supported the Matek H743-wing that I had bought. It is installed in a AR wing pro with the Matek CAN gps and TBS Tracer as Rx and controlled by a TX16S transmitter. Furthermore a VTX. I installed arduplane v4.1.0dev and is still using this version after a huge amount of flights. It took a while for me to setup arduplane and gain full telemetry, but the award is a very well flying wing! On the 2nd flight I used autolaunch with success and have used it in every flight since. I really enjoy flying in the area where I live. My goal is now to upgrade to the 4.2.0 release. Furthermore, I would like to be able to see the live flight in missionplanner so a little more investigation is required from my side on how to do that :slight_smile: . Thank you for the work!


ESCs do not get signals from Pixhawk Cube Orange. Motor signals are not visible in Mission Planner Servo Output. Board Arms fine, and all servos work ok. The flight controller operates the ESCs perfectly using ArduPlane 4.7.1 Official. So there is a problem with this beta version.

Does anyone have any suggestions how to get this beta version to work with the Pixhawk Cube Orange?


The flaperon function does not work in v4.2.0(BETA 2). On a F765-WING with version v4.1.7 they work almost perfectly (FLAP_SLEWRATE never worked for me). I update to v4.2.0(BETA 2) and the flaperons don’t work, I go back to v4.1.7 and everything works again; Obviously without changing anything in the configuration.

That is why I suppose that there is some problem or some change in the way of configuring it in v4.2.0 (BETA 2)

@Lano can you please send me a log file (from which I can extract your parameters).
I’d also like to know how you are testing (ie. how you are setting flaps).
The only significant change with 4.2 is that FLAP_SLEWRATE now allows for much slower slew rates. I’ve just tested flaperons in SITL for 4.2 and it is working fine for me.

i’d need to see your parameters, or preferably a log file. I use a CubeOrange on multiple aircraft and ESCs work fine, so there is something specific with your setup.
What type of ESCs are they?

The data that I send you is in the workbench, not in flight. To activate the flaperons I use both a 3-position stick and a slider that both act on channel 15.

The settings that affect the flaperons are:




these settings are the same in both v4.1.7 and v4.2.0(BETA 2)


v4.2.0(BETA 2)

Hi Tridg,

I have performed a series of experiments below that will provide insite to the problem:

  1. flashed Copter Official
  2. flashed Plane 4.2.Beta
  3. Turn on TX - Connect 4S bat - motors not tilt in responce to connection to flight controller - Connected MP via Mavlink Ant - MP not Arm - can see on params that things are not right
  4. downloaded full scale param.file - MP arms
  5. restarted system: tx on - Conn 4S bat - motors still not tilt in responce to connection to FC - wheel servos work - can see in Servo Outputs tilt servos not connected (no green bars) - see motors working!
  6. connected battery to ESC and

*ESCs now working in Plane 4.2 Beta!!!

  1. can see Q parameters have changed and some missing - Changed Q_Tilt_Enable=0 to =1 and reloaded full scale 001 param file - this fixed the missing Q params (before this it MP planner complained that 10 Q param missing, and gave a list!)
  2. restarted system: TX on - 4S bat connect (now get correct tilt motor responce as FC connects) - MP Arms ok - can tilt front motors using rudder stick and TX right finger control

*But ESCs stoped working!!! - MP shows in Servo Output that there are no motor signals (no green bars)

These tests were interesting! We got the ESCs to work in Plane 4.2 Beta by changing Firmware from Copter to Plane. But the ESCs stoped working when we loaded the parameter file for the 2nd time after I set Q_tilt_enable=1 (note ESCs worked when I loaded the full scale 001 parameter file the 1st time). The problem seems to be one of the 10 tilting parameters that were missing and had to be activated using q_tilt_enable=1: the missing params included: q_tilt_type, q_tilt_max, q_tilt_yaw_angle, q_tilt_fix_angle, q_tilt_rate_up and dn …

Perhaps this can give you an idea of the problem.

Here is a link to the parameter file I used:

Here is a link to the last log file in MP corresponding to these experiments:

Thanks, William

Here is a picture of the list of 10 parameters Mission Planner said were missing:

Hi Tridge,

We found the problem and have Plane 4.2 Beta now working well with my Pixhawk Cube Orange. The problem was that the pwm max/min parameters were set to zero. Once we set them to 2000/1000 respectively, the motor signals began to work properly and the ESCs started working.


1 Like

The v4.2 log shows it is working fine. You have FLAP_SLEWRATE=1, which means the flaps move extremely slowly. A value of 1 means maximum of 1% per second, so it takes 100 seconds for your flaps to move through the full range. Try using FLAP_SLEWRATE=50 for a more reasonable value.

Thank you very much for the quick response. It’s clear that the FLAP_SLEWRATE parameter is set to a ridiculous value. I guess as in v4.1.7 it was never satisfactory and the flaperons worked (fast but they worked) I forgot about it and when I used v4.2.0(BETA 2) FLAP_SLEWRATE did its job.

Now I don’t have the possibility to reinstall v4.2.0(BETA 2) but when I can I will try it and confirm to you that it works correctly.

Thanks again for your fantastic work.

1 Like

I was able to install v4.2.0 (BETA 2) again on an F765-Wing and the flaps/flaperons work perfectly. The FLAP_SLEWRATE parameter also works by allowing for smooth unfolding and retracting.

By the way, I also tried the rpm issue (telemetry) and it also works perfectly.

1 Like

I’ve just released plane 4.2.0beta3. This is the 3rd beta of the 4.2.0 major release. This beta should be close to the final 4.2.0 release.

  • fixed pitch envelope constraint after AIRBRAKE
  • improvements to POSITION1 quadplane landing controller
  • added arming check for Q_ASSIST_SPEED
  • added warning if arming with ARMING_CHECK=0
  • added arming check for DO_LAND_START with RTL_AUTOLAND=0
  • improved throttle mix for quadplane autoland
  • added fence breach message on GCS
  • constrain indexing on declination tables

Happy flying!


Pitch PID not working. Nav_Pitch signal tracks Pitch when motors off, But when motors turned on, Nav_Pitch signal rails to zero and does not track Pitch signal anymore. I am using the same PID values I used before using Arduplane 4.2 Beta. Here is a log file of the test:

Thanks, William

p.s. Here is a link to see the vehicle I am testing:

I’m the guy building the F-35B.
I am running a YouTube channel.
from 4.17
in both
There is no reaction of TailTilt Servo (Function 39).
I would really appreciate it if you could put a forced reaction option.
Is this only possible with a tricopter?

I don’t really understand what you mean. Looking at 2.bin I see:

this shows a huge amount of noise on the pitch gyro axis. If we look at the PID we see:

so we are seeing activity in the pitch PID as expected
looking at the pre-mixer rate outputs:

we do see demand going to the motors on the pitch axis (plus lots of noise)
and here is the motor outputs:

can you explain your issue in more detail?