Servers by jDrones

Plane 3.8beta6 motor troubles

beta-release
arduplane
pixhawk

(Tim Squires) #1

Hi,

Running OK on plane 3.8beta5 and I thought I’d update to beta6 but the motor will not start after the upgrade. All looks happy but there’s no output to the motor. Tested with multiple motors and ESCs with same results. Also tested on two pixhawks with same results.

Reloaded 3.8beta6 (via Rover firmware to clear everything down) but no luck.

Loaded 3.7.1 and everything is working again. I’d like to go back to 3.8beta5 to check that it’s the change from beta5 ro beta6 that’s the problem but I can’t find the download. Can someone please send a link to beta5?

If it’s confirmed, I’ll open an issue and upload the log.

Thanks.


(Greg Covey) #2

Plane v3.8.0 Beta 5 is here. You can also load it using the “Beta” link in the firmware load page of Mission Planner.


(Tim Squires) #3

Thanks Greg. That link provides the Beta 6 files, the Beta 5 file is not easily available anymore.


(Pompe Cukor) #4

Did you figure this one out?

Was out to maiden with 3.8 2 days ago and motors did not spin in manual more, there was throttle input (received from RC), just not output.
It worked fine in FBWA mode and auto and loiter. Just not in manual.
I will have to check again in the lab, be too busy, could have been something crazy on my part, but I have setup a few of these. The only thing new was the 3.8. I was on 3.8beta5 before this and that was fine. Also quite use to the servo out funtions aswell.


(Tim Squires) #5

Hi - I’ve been flying on 3.7.1 for a few weeks and all’s been ok apart from FlightDeck would not work so just used an old 3dr 433MHz radio pair to view telemetry.

Updated to 3.8 last week and everything is working great, including FlightDeck.

That was on a Pixhawk 1 - I have been having issues with all my Pixhawk 2.1s where I warm up in the car and then carry it to the take-off area. By the time I get there, the gyros are inconsistent and will not allow me to arm. The easiest way to find this out is listen to the audio on Mission Planner. It was driving me mad because no output on the Flight Screen - turn on audio and it’s literally shouting at me. :slight_smile: Just a power cycle fixes the problem.

I’m not keen on power cycles with companion computers because they prefer a shutdown and that takes time.

Hope that helps.

Tim