Servers by jDrones

Plane 3.8.1 released

(tridge) #1

I have just released plane 3.8.1 for your flying pleasure.

This is a bugfix release for 3.8.0, with just a few small changes, and
only one new feature.

The bug fixes are:

  • removed TRIM_RC_AT_START option, as this was causing significant issues
  • fixed bug in TRIM_AUTO support with differential spoilers
  • fixed bug with RCn_TRIM == RCn_MIN in MANUAL mode
  • fixed combination of TKOFF_THR_MINACC and TKOFF_THR_DELAY
  • fixed a bug in sending STATUSTEXT messages on all MAVLink channels

The new feature is that you can set the protocol for the debug UART on
FMUv2 or FMUv3 board (such as a Pixhawk or Cube) to allow allow UART5
to be used for arbitrary protocols. To use this fetaure just set
SERIAL5_PROTOCOL to the desired serial protocol. This should be useful
to users who have multiple serial devices (such as rangefinders) they
want to connect and have run out of UARTs.

Happy flying!

(Matt) #2

Is the serial 5 thing in master for all vehicles or only plane. We need this in copter too!!

(tridge) #3

It will be in future releases of all vehicles, plane is just the first one with a stable release with the feature. Planes are faster at most things :slight_smile:

(Colin) #4

Any new"s on I2c led driver for external led ?

(oscarCK) #5

Have you seen Mavpixel? Haven’t tested it yet, but it was the only configurable external led solution I found.


(Matt) #6

lol, Awesome! I’m running out of serial ports and have no need for debug, so that’s great. Thanks for getting that worked out.

(Erwin) #7

Hi! I have a pixracer board here, I have been using it with Arduplane 3.7.x and Arducopter firmware for a year. and recently, I tried updating it with the ArduPlane 3.8.1. Everything was setup properly, but when I tried powering it with my lipo pack, the esc does not seem to recognize the cells, no beeps. Normally the flight controller will send some PWM values to the esc so it will know how many cells are there in the lipo. And since no beeps where emitted by the motor, I can arm the plane but the motor has no response… I removed the lipo, plugged the Pixracer to my laptop to power the pixracer, and immediately the motor beeped, then I plugged in the lipo, and yes it armed and the motor ran… Again, I removed the usb cable and lipo, tried powering the pixracer with a lipo only, the issue is back,no beeps from the motor… I tried reverting the Pixracer to Arduplane 3.7.1 and throttle works…motor beeps normally. but then after I upgrade to 3.8.1 the problem is back… For now I replaced the pixacer on my plane with a pixhawk lite, flashed it with 3.8.1 and it works flawlessly. Perhaps some bugs with the Pixracer when running AP3.8.1?

(Kikislater) #8

It was the same with 3.8.0. solution is to adjust servo3_min/trim/max and rc3_min/trim/max.

(Pompe Cukor) #9

Are you suggesting that this release which was piratically done to fix this bug, does not actually fix this rc3 in bug?

(Kikislater) #10

No, I think you are talking to the other problem for reverse thrust setup then switching to manual to control throttle. For me it’s not the same issue, it’s about moving previous 3.8 parameters to actual.

(Pompe Cukor) #11

I see, yes. I my case was the issue mentioned in the corrected bug, which was the reverse trust and manual mode. Sorry.

(Erwin) #12

what should be the values for servo3_min/trim/max and rc3_min/trim/max.?