Servers by jDrones

Plan screen will not load

Has anyone else had an issue with the Plan screen not loading on MP 1.3.73 on Windows 10? It was working fine but perhaps due to a windows update it is not working now. All of the other tabs work except Plan.

what do you mean not load?

Hi Michael. When I would click the plan tab everything under the upper menu bar (map and side menu) would turn black and MP would freeze and not respond.

I uninstalled and re-installed MP only to have the same problem. Only when I deleted all of the folders relating to MP in my Documents folder as well as Program Files did it work again.

I have flown hundreds of flights over many geographical areas since installing MP so I am guessing there may have been too many cached tiles/ temp files/ Tlogs etc? Now that I think of it MP had been opening slower and slower each time over the past several dozen missions flown. After the fresh install it opens almost instantly.

Let me know if I can provide additional info. Thanks!

I’ve been having the same issue, takes around 5 minutes to load the plan tab sometimes. I tried clearing .tlogs with seemingly no change in load time so I don’t think that’s where the issue is coming from

One of our field laptops produced the same issue, so i was able to investigate it. It seems that the reason for long flightplanner load time is an overpopulated poi.txt file in the Documents/Mission Planner folder. If you delete it then everything goes back to normal. The POI file on this particular laptop contained almost 1500 lines.
Could you check yours ?

Was it load time or render time being the issue?

Looks like load time issue. The POI.UpdateLayout() runs at every FlightPlanner.Activate() and with 1500 POI it took quite long.

Yeah, that worked for me as well, mine was at around 4500 lines, clearing it out has made the plan tab open/load immediately again. Thanks.

i never knew the POI was used this much. so ill look into this

there will be a new beta in a short while that resolves this delay.
fix is here

Servers by jDrones