My PixRacer died after it hit the frame on my 250 - the “gets hot on USB” symptom.

Damn shame, actually. It was a relatively minor crash, compared to some I’ve had, but for whatever reason the PixRacer wasn’t seated in its vibration mount properly - possibly from a previous oops.

The vehicle had flown in the same configuration for several hours before this.

It is possible that the minor accident mechanically tickled something else, causing an over-volt on the inputs to the PixRacer - but it would be awfully odd/unlucky. I think it more likely that specific knocks to the PixRacer are flexing the board and causing something to come unstuck. @Gunaveh - are you in a position to reflow one of your dead boards?

No but I would gladly pay someone to have a try at it if it was cost effective. I feel the same way about my first incident. It was a relatively slow speed hit and I noticed that when it was plugged in via usb the board would get hot. This board didn’t have the same “hot” symptom but it wouldn’t work after crashing and still remaining glued to the gel mounts.

Your case seems interesting to me. I am not developer of any FC board, but I have some experience with hardware and software troubleshooting. You can send me any of your bricked/dead pixracer and I can try to do my best to discover what exactly is going on. In case it will be possible and needed I can try to reflow it with hot air gun and preheater. Then I can send it back to you.

I don’t need any money and I cannot promise any success. But if you would like to try then I’m ready.


BTW, is there chance in a crash that wifi board connector by its back side (soldered one) touched any carbon parts?


Good news and bad news.

I now know exactly what killed by PixRacer.

The bad news is that I know that because I killed another PixRacer :-/

So it turns out that there was some damage I hadn’t noticed on my 250. A signal wire to one of the ESCs frayed and could be intermittently shorted to the (3S) power line. First time it was probably some thick grass pushing against the wire. Latest time was me fat-fingering the situation.

So: PixRacer’s really don’t like 12V on their ESC signal lines. I think I can forgive the design that!

@Gunaveh Suggest you might try checking for anything bodgy in terms of the RC-Out wiring.

@dipspb Thanks for the offer! I don’t think anything but replacing the stm32 is going to fix this problem, 'though; @pkocmoud could probably confirm that.

Lesson learnt: pay more attention after smashing things into the ground at high speed!


Well after installing another pixracer and wrapping it in light foam and mounting with a total of 6 pads of zeal tap, I’m almost 100% certain that something bumping the case is killing it. In a couple weeks I should have a new case that will be virtually crash proof.

Mine has only the bottom part of a 3d printed case, because the top would knock on the frame, and has already suffered some unintended “landings” and still no problems, but YMMV

i also bricked the auav pixracer.
I get managed to replace the stm chip.
Does someone know how do i flash the Firmware on the pixracer?
Thanks a lot!
Best Regards

found it:

Pixracer is PX4FMUv4

Contact your seller to point you to the correct file.

got the right file.

Still no reply from auav. Does anyone else have any ideas for reviving these
boards? I have 3 now.

Are they all dead in the same way? e.g. getting stm32 gets ridiculously
hot connected to a USB port?

Was there something in common in the situations they died in? e.g. were
they all powered from the same power brick when they died?


I got the same problem with my AUAV pixracer. only 2 days ago everything was fine and i was just working on stability of flight at home - tuning PIDs and RC rates. No crashes ever - i use this platform for camera recording only. ECSs are OPTOs. power board is the AUAV made

today i powered it on from the battery - and nothing happens.

tried USB - also nothing. the Green LED is on, GPS and RX are powered (via the USB voltage) but the FC wont boot.
It doesn’t register with the PC either. Also noticed that the case is much hotter than before.

mkolesnik@kolesnikt530:~$ ls -lstra /dev |grep USB
mkolesnik@kolesnikt530:~$ ls -lstra /dev |grep USB
mkolesnik@kolesnikt530:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04f2:b44d Chicony Electronics Co., Ltd
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The inability for the pc to register it as connected and the board getting hot are the same symptoms im having with the handful of pixracers i have as well. I contacted auav about it and they only suggested i had wired it incorrectly. I hope more people bringing up this issue will cause the company to take it more seriously.

same here. my pixracer is suddenly bricked too, last week everything was ok, but today only solid green light. no recognition by Windows and Linux.

USB only the same as powered with power module.

all peripherals were disconnected.

Any ideas?

i bought a new one… :frowning:
and isolated all connections, so there is no possiblility to shorten it.

I am also having same issue, only solid green light. no recognition by Windows and Linux. Chip heats up quickly when powered via USB. Is there any hope to recover this board or it is beyond recovery?

you can change the stm32 chip. I’ve done this but i cant load up the right bootloader.
Maybe it is becourse i took the stm32 rev1 chip.

regards a.

2nd pixracer bricked :frowning:
don’t know why. everything was isolated.

Here is the logfile:


does someone has a idea why the pixracer bricked?

Thanks a lot!

BR anton