Pixracer with Dshot, Servo jitter

Hello all,

I am using a Pixracer (recently purchased from Mrobotics) to control my autonomous solar drone boat. See here: http://www.skyviewcustoms.com/champlain-explorer

This boat has been run successfully while using a Mateksys 405CTR. I had some overheating issues with the main processor and figured it might be caused by the built in voltage regulator. This is why I switched to the Pixracer (plus more redundant sensors).

I have used Dshot with esc telemetry successfully with the 405CTR board but have extreme servo jitter with Dshot enabled with the Pixracer. I even have jitter before arming. If I set up the MOT_PWM_TYPE to “normal” the jittering goes away and the servo works as intended. I’ve also tried setting the BLH_SERVO_MASK parameter to just the Servo 3 output (motor) but still have issues. Is Dshot being pushed to the servo channel as well?

The servo is powered from a separate voltage regulator so just the ground and signal wires are connected to the servo 1 port on the Pixracer.


  1. 1 X rudder (Servo 1)
  2. 1 X motor/esc drive (Servo 3)
  3. ESC is blHeli32
  4. Ardurover 3.5.0

Please see attached pics/log file.

Any help fixing this would be appreciated


Try configuring the Motor and Servo into different motor groups. From the Hwdef file I think there are 2. Chan 1-4 and Chan’s 5&6.


The use the BLH parameters to specifiy Dshot for the motor. I haven’t tried this, just a suggestion!

Thank you Dave. This was the correct solution! More can be seen here: