Servers by jDrones

Pixracer R14 Telemetry with FrSky R9 Series Receiver Not Working

Hi, everyone.

A couple of months ago I wrote here about a telemetry problem with the Pixracer R14 FC running Arducopter, and the problem was solved (http://discuss.px4.io/t/pixracer-r14-frsky-x4rsb-taranis-x9d-telemetry-not-working/7510/2). After 2 months, I’m restarted working in my sub 250g drone. Now, I’m using a Pixracer R14 running Arducopter 3.6. Telemetry and everything else works well using the Frsky X4R receiver, but not with the long range Frsky R9 series. I’ve tried R9 Slim and R9 Mini, and both did not work with telemetry. I just get Batt and RSSI values, instead of the 13 values given by the full telemetry as in X4R. Does anyone got Pixracer working with a full telemetry using some Frsky R9 series receiver? If you did it or know anyone that did it, please, help me. Maybe it is a bug and must be solved. My surprise is that I did not found any setup like this in the web (Pixracer + R9 receiver).

Regards and thanks in advance!

[]s!

Only one more observation… I’ve tested R9 Slim and R9 Mini with a Navio2 Flight Controller running Arducopter and telemetry worked perfectly. I’ve got about 20 telemetry values on my Taranis.

Regards!

I’m used Pixracer V1 and X9R with sport telemetry.
Then just replaced X9R with R9Slim, did bind and got telemetry working as with X9R. No any additional reconfiguration.

Ensure you have bind with telemetry option and your R9 firmware is SPort, not FPort.

BTW I have another issue with R9 telemetry - if it disconnected once (because of a distance) then it never reconnects again till restart of the receiver.

I have no problem with Frsky telemetry using an R9 Rx with PixRacer either but I’m using Frsky Passthrough (option 10) and Alex’s excellent Yaapu Frsky telemetry solution. In fact I use that for all craft regardless of the Rx.

Okay. Thanks for your answer.
But what telemetry output port of Pixracer do you use? The normal MavLink port or the FrSky port?
Using Yaapu solution, do I need to detect telemetry sensors on Taranis on the script do that?
Thanks and best regards!

Okay, Sergey. I’ve tried with correct firmware and bind option. The difference is that my Pixracer version is R14. Maybe the problem is with this version. I’m using with a conversor made with Teensy 3.2 and works perfectly, but I’d like to avoid one more hardware, since this is a sub 250g quad.
Thanks and best regards!

The Frsky port and set the protocol to 10. The script will detect most parameters but you can run detect anyway in case you have some Frsky modules.

You don’t need a Teensy.

Okay. I’ll try again. What serial port number are you using for FrSky port? Is it SERIAL4? Thanks again.

Right Serial 4. Connect the Tx and Rx from the PixRacer Frsky port together (short them) and connect one wire to the Rx Sport signal pin.

Man… Guess what? Using Yaapu script and FrSky Telemetry Passthrough everything worked like a charm!
But the sensors are not being detected in the Taranis detector. No problem.
Thanks a lot, man. Best regards!

Great Ricardo! Yes, It’s a very nice solution, I’m using it on all my craft. You can post on Alex’s Blog here for help, he’s very responsive.

Servers by jDrones