Pixracer PX4FLOW optical flow

Hi I am trying to use the pixracer and the px4flow camera. Im running 3.5.4 and when I connect the px4flow I get bad opt flow health in HUD. When I connect the same px4flow to the normal pixhawk running the same firmware it works fine I get opt_x and opt_y data. Is there a difference in the firmware for the pixracer (px4_v4) vs the normal pixhawk (px4_v2)? Has anybody had success connecting the px4flow to the pixracer? I read from Guilaume’s in March '17 post that the oflow was disabled for V3.4 but is that the case for V3.5 and if so how would I re-enable it?


I’m using a PX4Flow module on a pixracer running arducopter 3.5.5, it works.

Do you have a laser distance measurement showing up as sonar-range?
Is opt_qual high? (i tried to use PX4Flow without updating the firmware and it kept switching between high (>200) and 0.
When you move the vehicle do opt_x & opt_y become non-zero?

I suspect that you have a power supply issue.
Pixracer can’t get as much current as the PixHawk.
Try using a ubec to feed the px4flow and make sure you have common ground

1 Like

Hi Nando, Im getting a distance measurement for sonar range. Im using a teraranger one lidar. The opt flow quality shows a zero as well no matter how good the lighting conditions are. Everything shows zero despite moving the vehicle around.

Thanks ppoirier! We are trying to power it from another source will know in a few hours!

HI ppoirier, mission planner now recognizes the optical flow camera thanks! Now the issue is that the camera seems stuck, the opt_x and opt_y and opt_quality arent moving despite moving it around it well lit conditions. Do you have any ideas of what might cause this?


As per wiki make sure you flash the right firmware (KLT) http://ardupilot.org/copter/docs/common-px4flow-overview.html#upgrade-the-px4flow-sensor-s-firmware
btw, it is easier to flash with qgroundcontrol

With the KLT firmware , you have to look at opt_m_x, opt_m_y if the sensor is operating you should see non-zero when moving the camera

Just like with the RangeFinder, make sure the px4flow is power properly (UBE is still the best option)

1 Like

Worked, it was the camera it was defective Thanks!