PixRacer pix... but not racer... and no fun

I’m a fairly new Ardupilot user. After first positive impression from a “big” px4 in a 600 class hex’a and losing my naze based 250 I decided to buy a pixracer for my new build.

I’m starting to regret that decision :frowning:

While setting up the big pix was a big pleasure, setting up pix in a overpowered (ctune hover is at .19-.22 on 3s while a 4s setup is destined) 250 is a nightmare. No matter how an what I set (at least in the standard parameters - all the settings still overwhelm me) the copter is far from stable. A constant wobble always accompany me spoiling the fun.

Today I decided by hand test tune the pids - I lowered all all the way down (P I D) setup the CH6 P tune. Even at a very low P setting, the copter is very soft but still wobbles.

That was a very expensive experience. For the pix I could have purchased almost 3 sp F3 evo boards.

eliminate the vibrations, and possibly increase the value INS_GYRO_FILTER
I wish you success

I was on the same boat as you earlier but I was using a Pixhawk micro. The tip is to lower your vibration and right parameters for a small quad. I use Kyosho gel when mounting my pixhawk. I also followed this post by Leonard Hall.


I am still on 3.3.3 until I see a more stable 3.4 build. I am enjoying acro and auto missions now.

Hi Qemay,

Depending on exactly what your setup is the parameters can vary quite a bit. Here are a couple of pointers.

Starting Parameters:

Make sure you are running 3.4-rc1

I find that with esc breaking on I need to drop my rate pids right down.
So keep halving your rate pids on roll and pitch from default until you can take off and not get oscillation. These are the parameters I am talking about here:

Don’t be surprised if you have to drop the d terms to 1/4 the defaults.

From here you can start doing manual tuning. Increase the D term until you get oscillation then divide by 2 or back it off until you remove the oscillation. Do the same for the P term. Then set the I term to be equal to the P term.

Then you should be able to do an autotune.

Hope this helps. Let us know how you go.

Don’t get me wrong - it does fly. Just not the way it should. There is a wired oscylation - no a wrong word wobble - on the whole range of settings. I can set the P all the way down but the wobble is always there. It acts kind of drunk. It slowly (1-1/2 hz??) dips different ways - and it’s most noticeable when you make it hoover stable. The wobble is different from the usual P oscillations. The P oscillation is constant on an axis. the wobble dips different ways with no apparent scheme.

Yesterday I fallowed your advice. After increasing INS_GYRO_FILTER to 40 the wobble seams to increase it’s frequency. At INS_GYRO_FILTER 80 it starts to resemble the P oscillations but it’s not as predictable.

Also after trying to tune it with the CH6 Opt to “Rate Roll/Pitch kP" from Min to 0.08 it wobbles even at the minimum. Where the copter is far from being flyable as it is very soft and not responsive and still wobbles. When I make it responsible the wobble is still there. When I increase the P father it starts to oscillate the usual P way on top of the wobble. I can get the P oscillation out, make it flyable but with the wobble. Using this guide http://ardupilot.org/copter/docs/ac_rollpitchtuning.html#ac-rollpitchtuning

The only difference is i test it in hand. Arm (in acro), take the copter in hand push the thro to about hoover point, and change the P with the CH6 knob.

After the test I got constant EKF errors and gyro bad health. After reset they are away.

Still did not try to put the racer on a some kind of foam or gel as I don’t have a case for it yet and it would be hard to put it level on a foam without one.

Hello Qemay,
that seems a tüpisches vibration trouble to sein.die small quads are under very hard, so that the vibrations are very hard. we have made very good experiences with velcro under the FC. the drive shafts are not bent. the propeller balancing.

I wish you success

best regards

Rainer Kayser

Today I will print myself a case for the pix, and put it on a velcro. I can also try a heli gyro foams. I don’t think I have any msheli gel pads more - because I could try those to.

Leonardthall - you mention ATC_RAT_RLL_FILT ATC_RAT_PIT_FILT- where should I update those - I can not find anything like this on parameters list, and Roll and Pit Filt on extended tuning page are gray and I can not edit those.

Hi Qemay,

That sounds like gyro aliasing. This is where the high frequency vibration is translated to very low frequency vibrations.

let us know how a little vibration isolation works for you!!



Newby here (new to Arducopter/pixracer but not new to mini quads)

I just had a horrible experience with an attempted maiden flight on a superlight, over powered quad (diatone blade 180, 1306 motors,3s) with a Arducopter/pixracer.
I pretty much started with the default pid and setting numbers and move all the sliders to the left.
After 4 broken props, I still cannot get it to gently lift off the ground or close to hover.

I found this post and your blog post

I was wondering if there are updates related to the latest AC release? I’m going to try these settings in your blog tonight.

Coming from successful builds on other flight stacks, I’m realizing the learning curve is steep for Arducopter.

Thanks in advance.


I have done all the described parameters in first post.
My 250 copter fly much better now.

In the first post you recommend 3.4-rc1
Please where is it to find?

Jochen Causemann

If you want to try a Beta release I would suggest 3.5Rc5. Install from Mission Planner selecting the “beta firmware” button. I’m flying a Pixracer on a 210 size quad with it and it’s performing well.

Found. Thank you.
I will post the results on my PixFalcon.
Best regards
Jochen Causemann

It seems that 3.5Rc5 does not work for me on PixFalcon out of the box.
With 3.5Rc5 I get "Failsave, No Receiver"
But i can see all sticks movements in Mission-Planer.

I moved back and installed 3.4.6 Quad.
Everything works.

Have i missed something?

Best regards
Jochen Causemann

I am using pixracer with arducopter firmware 2.4.6 , autotune pid fly well.