Servers by jDrones

Pixracer not detecting external compass


(Matt88) #1

I’m using 3.4.6 in the hexacopter variety. I have tried everything. Also using a m8n gps/compass combo and the gps works great however the compass is never detected? Tried switching out sd cards as another poster stated helped his problem with a similar issue. I’ve tried different firmware,px4 fw,tried swapping sda/scl around. I have tried loading fw and calibrating thru apm planner,mp,and qgc. I am currently on mission planner with arducopter 3.4.6. Also tried a different gps. None of this has worked? Listed below are the only two device ids that show up? Aren’t these both internal? Compass one gives offsets consistently in the 700-800 range on the z axis only so it is unusable. Compass 2 gives offsets in the 200-300 range on all 3 axis and when I try to use it as the primary compass it will fly in loiter but after moving around a bit I start getting compass variance errors and toilet bowling? Any help would be much appreciated,Tks.

COMPASS_DEV_ID,66826
COMPASS_DEV_ID2,263178


(Lorenz Dobler) #2

Hi,
I have also some pixracers running, but I am using those on quadrocopter with 15-17 inch propellers. Also one Arduplane.
One copter uses a Ublox NEO-M8N, the onter one a Holybro micro M8N module. They work with the settings they came. I just told MP that the first compass is externaly mounted and I had to reboot the pixracer and they are working. I have red somewhere that there are optimal settings for the use with apm copter, like 5hz refresh rate etc.

BR,
Lorenz


(Matt88) #3

Thanks for the reply. I had the seller send me a replacement pixracer. The compasses work as expected now. I am still having an issue with the battery monitor?? I have tried to set it up in mp using several different settings and none of them work correctly? When I set it up like my pixhawk with the (other) option selected I can change the voltage divider to get the voltage to show up correctly but once it does it never changes? It appears to be running off of a regulated voltage source? The current is the same. It will bounce around 1.8-2.0 and do nothing else? I used the pixracer schematics to wire it up to the battery monitor so it should be correct? I will test with my volt meter this evening tho to confirm the wiring of the power module? Doesn’t make sense that the same power module wiring would work w pixhawk but not the pixracer tho.


(Paul Atherton) #4

Matt,
Are you using a regular APM style power brick? If so, this has its own voltage regulator which provides a 5v power supply to the Pixracer, however the voltage it is reading is that of the main flight battery connection. It also reads the volt drop across a very low value resistor to determine the current reading. These are fed to the pixracer on the two center connections of your power connection to the pixracer and are designed to provide 3.3v max. Your calibration within Mission Planner, you should read the actual flight battery voltage (with flight battery connected to the power brick) using a multimeter or something like the HK power meter (see here: https://hobbyking.com/en_us/turnigy-180a-watt-meter-and-power-analyzer.html), and type this voltage into the “Measured Battery Voltage” field in Mission Planner, and MP will then calculate the voltage divider for you. The same applies to the current reading - which again can be read with a power meter once you put the copter under some load - so maybe props turned upside down and moved one place around, so that what you spin them up, it creates a load and pushes the copter ground-ward (for safety). You can then read the amps measurement from the meter and enter this in the “Measured Current” field in MP. I setup my Pixracer using this very process just last week, and worked fine.


(Matt88) #5

i did use a multimeter as you suggested but I didn’t measure it while it was under a load. I swapped the center pins and have now gotten the voltage to show correctly but the current never changes from the original value I entered from the multimeter? I will try again while under a load. I am using the apm power module


(Lorenz Dobler) #6

Hi Matt,
I just had a problem with my voltage/current sensor (the original AUAV PDB ACSP4) - after upgrading the pixracer to APM 3.5 i got a correct voltage but the current was jumping from 10A to 20A with no load. I tried every combination of the settings for the power sensor - no success. So I updated to APM Plane and back to Copter 3.5 and it is working now with these settings:
Power Module: Other; Board PIX4/Cube, Volt/Amp: 36,36 but needs to be tuned under load…
So in my case it was some settings/update-problem… I guess


(Matt88) #7

Ok I’ll try 3.5,Tks. Using 3.4.6 now and I’ve noticed the voltage doesn’t show correctly in mission planner only shows correctly in qground control? Hopefully the devs will get this all worked out at some point?