Pixracer landing gera

Hi All
I try to connect pixracer and tarot TL65B44 landing gear. I changed SERVO6_FUNCTION to 29 I configure my taranis and assing Ch7 Opt to landing gear in extended tuning but no success…
First I try to connect landing gear direct to pixracer port 6. Second I try connecet trought BEC ( 5V) but the results are the same- no success.
Is it enought to change SERVO6_Fuction and ch7 opt or I have to configure someting more ???

When I duplicate your configuration on one of my PixRacers I see the chan 6 output PWM value change on a scope (don’t have a servo) and on the status screen in Mission Planner to the PWM values set by LGR_SERVO_DEPLOY/RETRACT (1750/1250 default). Action is also controlled by LGR_STARTUP. So I think it should work if configured for your gear correctly.

Did you know/remember that the servo outputs are not active until the satety button is pressed or deactivated? No landing gear action without the safety button.

Also there is no power to the output bus with the Pixhawk. Not sure about the Pixracer.

The PixRacer output bus is isolated.

If I connect landing gear direct to RC reciver and power reciverfrom BEC landing gear works…
I press safety button but landing gear still not working. I also configure LGR_SERVO_DEPLOY/RETRACT (984/2006) SERVO6_FUNCTION to 29 try to conenct only signal trought pixracer and power landig gear from BEC. It looks like pixracer dont send signal to pwm 6. I find information that that “+” pin dont provide the power but if it is true powering gear from external BEC should work…The question is pwn 6 in pixracer is really servo6_function ??? but still wit now success…
I have no idea how it configure

It does send a signal to chan 6. I tested it and its working. I see the exact PWM values set by the Deploy/Retract parameters on the output. It also shows on the status page in MP as I said but I scoped the output just to be sure.

Attached is the actual output from Chan 6 with the Retracr/Deploy parameters set for 1000/2000. You do understand that with LGR_STARTUP at default (0) on power up there will be no output until the switch is flipped? If you don’t want this change that parameter to either retract or deploy on power up.

Thx Dave for Your help