Pixracer Battery display in MP

With 3.3.4rc1 and an apm power module I find the battery voltage is always 0v in MP but displays correctly in QGroundControl.

Is the ESP8266 working in MP?

How many compasses should Pixracer display - I seem to have one external and one internal - but some are claiming 3 - I have compass envy!!


Yes, the ESP8266 works with Mission Planner. I have connected to MP, QgroundControl on PC and with IOS (iPhone).

Mine calibrates 3 compass’s in MP. 1 external and 2 internal, the 3rd with very high offsets.

You mean 3.4-rc1 right?

And do you have a genuine Pixracer?

I posted an issue with Pixracer and power module when I tried the PX4 stack on it and there was a fix put in place in the PX4 stack (I think, please correct me if I’m wrong) and QGroundControl which worked perfectly.

Not sure about ardupilot on the PixRacer yet, but it would explain why QGroundControl is operating correctly.

Maybe you should try posting in the MP forum?

I do not have a genuine Pixracer but a Banggood clone, and yes I mean 3.4-rc1. I won’t make any excuses for buying a clone as in the past I have a mixture of genuine APM/3DR products and one clone Pixhawk.


Well Pixracer clones are known for not working well (HobbyKing even removed them from their site and e-mailed buyers saying they would send a replacement when they had fixed boards). So, personally, I’m not pursuing something that is probably the boards’ fault.

I think I may have a duff Pixracer as the third compass is not recognised. Having looked inside the Pixracer I am not impressed with the quality of soldering, some areas look as if they should be reflowed again, including around the 5983 compass, and there is evidence of some hand reworking.

I think it is time to buy the real thing!


I have genuine Pixracer and it work well with MP on 3.4-rc1 or last 3.4dev. There is only issue I could see is RGB LED of Pixracer does not work.
I saw this post and fixed it by myself, but no one make a RP on github.