Pixhawk4 Mini Engine problem


i use a quadrocopter with a Pixhawk Mini FC. After I have completed a few halfway satisfactory flights the following problem suddenly appears:

After arming all engines start normally. A few seconds later, one or two of the motors lose speed and finally stop.

Sometimes the following error message appears before arming:

“Preeflight: GPS Horizontal Pos Error to High”

Compass and the other sensors I have of course carefully calibrated.

The used board is a PX4 FMU V5. When loading the firmware I can only load the PX4 firmware, Ardupilot does not work.

Here is the path when downloading:


Does anyone have an idea?

Say thank you

Greeting Hermann

For PX4 support is here::

But if you want to use Ardupilot that FC is supported. Copter version here try using Load Custom firmware after downloading the .apj file. This assumes it’s the Pixhawk4 Mini from HolyBro.

Wiki is your friend:

Hello ppoirier,

thanks for the hint. Unfortunately this does not solve the problem why two of the engines stop when I accelerate. The other two continue to run without problems.



Problem is solved. I have recalibrated the ESC, now it works again.