Servers by jDrones

Pixhawk4 install hangs APM Planner

APM Planner 2.0.26-rc2 (2.0.26-23-g718b06e)
Pixhawk 4
Firmware upload - Stable => Unknown Autopilot cannot fetch firmware versions.
Firmware upload - Custom => Screen hangs


As you can see it is on the right USB port,
Sees the PX4 FMU v5.x

Mac OS X 10.14.2 Beta (18C38b)

I am trying to load Ardupilot onto this board (to replace the PX4 FW) without success.

@mboland Could you please upload the log file? It would make it much easier to check why the flashing fails.
Downloading fails beause Pixhawk 4 v5.x is not supported at the moment. But if you send the log I will try to fix that too.

Here are 2 logs from the attempts I made.
First one is the ‘no firmware for this board’

apmlog_no firmware.zip (2.9 KB)

And this one is from attempts to load the firmware file already downloaded

apmlog_hang on ffw load.zip (15.1 KB)

If you need any more info or tests I will be happy to help.

@mboland Thank you for that!
I made some changes and adaptions in this Pull Request
If you are able the build the planner from this PR it would be great if you could test those changes.
If you test be aware that it will flash the ChibiOS (*apj) version of Ardupilot as there is no NuttX (*px4) firmware for a Pixhawk v5.x

I would like to but unfortunately I have not been able to get my head around GitHub PR’s.
Have managed to download and build Master Repositories following instructions, but doing this for an uncommitted PR escapes me.

@mboland just use the branch in my repo https://github.com/Arne-W/apm_planner/tree/FrimwareUpdate_improve. It would be very cool if you could test those changes as I do not have this hardware - and please upload the logs!

I switched bach to this thread as I did not want to “pollute” the RC thread…
@mboland Did you see http://firmware.ardupilot.org/Tools/APMPlanner/daily/2018-12-10/? Would be cool if you could test in the next days - and please upload a Logfile cause I added some output to check if everything works like expected.

I see the new version there now, 2 in fact.
So I downloaded both and I received the same result with both.
Does not see a valid device.
apm_planner_2.0.27-rc1-1-gde42621.zip (14.2 KB)

This log has the ‘Initial Setup’ attempt and then a connect to make sure the port was right and APM could talk to the PH4.

apm_planner_2.0.27-rc1-2-gfc70222.zip (3.5 KB)

This one is just the ‘Initial Setup’ attempt.
Same result, no valid device.

@mboland Thanks for testing :+1:
I adapted the code with the Informations from your logfiles and I hope the last changes will fix this issue.
As I pushed the changes tody there should be a new daily in the next hours.

@Arne-W just downloaded apm_planner_2.0.27-rc1-4-g562fa65_osx and it was able to see the PH4 and install the firmware without issue.

One very minor point.
On plugging the PH4 in during the FW upload (unplug and plug in instruction) the dialogue appeared about they’re being a new Plane FW version again. This was during the FW upload procedure so I am not sure if it would have interrupted the upload.
And after the verify and rebooting there appears an ‘unknown platform’ message in the output window.


apm_planner_2.0.27-rc1-4-g562fa65 log.zip (7.5 KB)
It seems to be triggered when the serial port is selected again, ie: during FW flashing the serial port changes to some non existent serial device, and after flashing it reselects the serial port and generates the message.
If I choose another port and then the PH4 port again it generates the message again.

@mboland Thank you for testing again :smiley: :+1:
I will fix your “minor points” cause I think it could confuse some users. I will inform you when it is fixed - somehow in the next days I think.

@mboland I think I have fixed the issues you found while testing. The unknown platform bug is fixed for sure, the new FW dialog bug should be also fixed as we stop scanning for new devices as soon as flashing starts.
So far thanks for all the testing and I wish you a merry Christmas :christmas_tree: :smile:

@Arne-W thanks for all your efforts in getting the fixes in.
The Pixhawk4 had to go back to the client so I don’t have it to test anymore.
I do hope you have a very pleasant and enjoyable Christmas. :santa:t3::christmas_tree:

Servers by jDrones