Pixhawk2.1 to MP / connection failed

I’ve been trying for hours to connect my newly purchased Pixhawk 2.1 with Mission Planner. But no success. Pixhawk is only connected to the GPS, no further connections, except USB of course. After connecting and clicking on install firmware (rover) MP displays the message that the connection failed.

What am I doing wrong? I´m quite lost.
Thanks for some ideas!

Obvious questions first.
Have you selected the right comm port?
Have you tried different cables?
Have you checked your device manager to see if there is any issues with the comm port?

Device manager shows no issues. …but only after installing Qgroundcontrol. When I installed MP the first time, Pixhawk didnt show up on Windows. Then deinstalled MP, installed QGc, Pixhawk eventually showed up on COM3, reinstalled MP, but still that problem in MP. I also deactivated all antivirus software and commodo during installation.

After updating to the latest beta I now find the firmware page broken as well.
I have uninstalled and re-installed the latest.
Still broken.
Updated again to the latest beta.
Still broken.

What I get is “There is no firmware available for this board” on Pixhawk 1 and 2.1.
So there is something wrong with the MP firmware page that has just cropped up.

Have you tried to just connect normally?

Connect normally means just with RC TX/RX? No, I still waiting for PPM Sum converter. Hopefully next week it will be delivered.
Now i tried three different Win7 machines, all the same result:
After installing MP, pixhawk appears on COM3 in device manager, but it says “no driver installed” and it is called blackcube-BL.
After installing Qgroundcontrol, pixhawk is seen correctly in device manager. Drivers are ok, and it is now called ProfiCNC CUBE F4 FMU.
But neither MP nor QGC can see it. MP shows COM3 to select, but it is not named like pixhawk or anything, just COM3. When I select COM3 and start firmware installation, it is searching quite long, 2-3 minutes, then asks if it is a linux board or not. Both options lead after another 2-3 minutes to the screen I posted above.
In QGC it says “waiting for connection” and nothing happens.
The pixhawk itself, after startup, is blinking orange for some seconds and then stays orange. The Here2 GPS is blinking blue slowly on the sides and flashing red on the top.
Is there any special meaning about that blinking pattern? The buzzer is installed but makes no sound.

…little correction: the red LED on GPS isn´t flashing, it just stays red.

…little correction again: :crazy_face: the red led on the GPS is flashing. Only when I press the button during startup, it stays red solid.

Quite strange, I now tried QGC on a Macbook, and it worked! Seems like there is some kind of COM Port issue on the Win PCs. All three PCs running Win7. Maybe updating to Win10 will solve the problem.

A normal connection would be to select comm3 and just hit connect (top right)

Do you get a connection?
There was an issue with the different drivers for Chibios that necessitated yet another uninstall and a fresh .msi install from the servers.
This apparently loaded new drivers, and the problem was solved on my machine.
I have confirmed with 2 different machines now that loading the beta update kills the firmware upload screen.

Now everything worked out. Seems like the problem was that on all windows machines was a comodo firewall installed. Even though I deactivated it during installation. Only after deinstalling comodo everthing works fine.