Pixhawk won't start, solid RED LED

I’m having issues getting the Pixhawk to talk with APM Planner. Further troubleshooting points me in the direction of solid red LED.

I’ve found a few similar posts that point to bad SD cards or users forgetting to insert a SD card. The Pixhawk came with a new SD card, and I have tried another working SD card, formatted FAT32. Still getting the same red LED. At this point I can buy a more SD cards, but I have a feeling that isn’t the issue.

Following similar posts it looks like the Pixhawk isn’t fully booting.

nsh> df
  Block  Number
  Size   Blocks     Used Available Mounted on
   128      618      618         0 /etc
nsh> sh /etc/init.d/rc.APM
Mounting binfs 
binfs mounted OK 
nsh: rm: unlink failed: No such file or directory
Detected FMUv2 board 
uorb started OK 
Trying PX4IO board 
PX4: param_find(SYS_RESTART_TYPE)
PX4: param_find(CBRK_IO_SAFETY)
[px4io] default PWM output device
PX4: param_find(CBRK_FLIGHTTERM)
PX4IO board OK 
PX4: param_find(RC_DSM_BIND)
PX4: param_find(BAT_V_SCALE_IO)
PX4: param_find(RC_FAILS_THR)
PX4: param_find(RC_FAILS_THR)
PX4: param_find(CBRK_FLIGHTTERM)
PX4: param_find(RC_RSSI_PWM_CHAN)
PX4: param_find(RC_RSSI_PWM_MAX)
PX4: param_find(RC_RSSI_PWM_MIN)
PX4: param_find(PWM_MAIN_REV1)
PX4: param_find(PWM_MAIN_REV2)
PX4: param_find(PWM_MAIN_REV3)
PX4: param_find(PWM_MAIN_REV4)
PX4: param_find(PWM_MAIN_REV5)
PX4: param_find(PWM_MAIN_REV6)
PX4: param_find(PWM_MAIN_REV7)
PX4: param_find(PWM_MAIN_REV8)
px4io: check CRC failed: -22: Unknown error
PX4IO CRC failure 
nsh: echo: open failed: Invalid argument

I get the above output with both SD cards and without a SD card. This makes me think something else might be wrong. Following these instructions [3] I should get similar output of [4] without the SD card and I am not receiving that. I am getting the same issues with Rover and Plane firmware.

nsh> ver all
HW arch: PX4FMU_V2
FW git-hash: 379ca5ac00008126408e1e67b8066112ade8c515
Build datetime: Jan 30 2016 05:13:57
Toolchain: 4.9.3 20150529 (release) [ARM/embedded-4_9-branch revision 227977]
MCU: STM32F42x, rev. 3
UID: 47002B:33345118:32353634 

Is there something I am missing or new SD cards?

Similar Posts
[1] viewtopic.php?f=21&t=14853
[2] viewtopic.php?f=21&t=12804&hilit=check+crc
[3] viewtopic.php?f=21&t=12804&hilit=check+crc#p34845
[4] uav.tridgell.net/NEVdD/rc.APM-startup.txt

Sent back in for RMA after talking with 3DR support.

New Pixhawk came in and looks like it is booting further, but now getting hung on sensors.
The new Pixhawk is
[li] Powering up[/li]
[li] Flashing just fine[/li]
[li] Writing to SD card[/li][/ul]

Here is what is currently happening when starting rc.APM

nsh> sh /etc/init.d/rc.APM
binfs already mounted                                                        
removed old boot.log                                                         
Detected FMUv2 board                                                         
uorb: already loaded                    
uorb started OK                         
Trying PX4IO board                      
px4io: already loaded                   
PX4IO board OK                          
px4io: CRCs match                       
<fmuservo> MODE_4PWM
<fmuservo> set_pwm_rate 0 50 50
Set FMU mode_pwm4 
Starting APM sensors 
[MS5611_SPI] on SPI bus 4 at 2 (11000 KHz)
ms5611: no device on bus 4
[MS5611_SPI] on SPI bus 1 at 3 (11000 KHz)
ms5611: no device on bus 3
ms5611: no device on bus 1
ms5611: no device on bus 2
ms5611: driver start failed
no ms5611 found 
Error in startup 
nshterm [31:70]

NuttShell (NSH)
nsh> nshterm [35:70]

Starting uorb to test the sensors

nsh> uorb start
uorb: already loaded
nsh> ms5611 start
[MS5611_SPI] on SPI bus 4 at 2 (11000 KHz)
ms5611: no device on bus 4
[MS5611_SPI] on SPI bus 1 at 3 (11000 KHz)
ms5611: no device on bus 3
ms5611: no device on bus 1
ms5611: no device on bus 2
ms5611: driver start failed
nsh> ms5611 test
ms5611: bus 0 not started
nsh> mpu6000 start
mpu6000: driver start failed
nsh> mpu6000 test
mpu6000: /dev/mpu6000_accel open failed (try 'mpu6000 start'): No such file or directory
nsh> hmc5883 start
hmc5883: no device on bus 2
hmc5883: no device on bus 1
[HMC5883_SPI] on SPI bus 1 at 5 (11000 KHz)
hmc5883: no device on bus 3
hmc5883: driver start failed
nsh> hmc5883 test
hmc5883: bus 0 not started

I’ve tried stable ArduRover (2.50), ArduPlan (3.5.0), and ArduCopter (3.3.2). I’ve also tried naked Pixhawk and with everything plugged in, no difference that I can tell. I do get a log written to SD card saying MS5611 failed to boot.

From searching forum and google looks like another bad Pixhawk?

Here is a video of the pixhawk booting with and without holding the arm switch. vimeo.com/156102335

Coordinated with 3DR support and they confirmed it is another bad Pixhawk. Basically the Pixhawk should never go to a solid red LED. If the SD card is working then its bad hardware. Maybe 3rd time is the charm…

Interesting. I’ve pretty much given up on buying PX/APM hardware from 3DR anymore. After they launched the Solo they acted like their hardware customers didn’t matter. At least that was the impression I got when I had a go around with them about some I2C splitters that took two weeks to ship when I ordered them priority.

My brother bought a clone kit from getfpv (FC/GPS/Compass/Telemetry/Power module together) for just over $200 US. Buying the FC alone from 3DR is just 10 dollars cheaper than that.