Pixhawk won't connect to Mission Planner

I am having trouble connecting to the Mission planner all the sudden. I am able to upload firmware and change firmware versions, and I used to be able to connect via both radio and USB cable, however I no longer can connect either way. Once before I couldn’t connect via USB, but changing it to auto worked, that isn’t the case anymore. I tried re installing the firmware, reinstalling the mission planner changing the baud rates, and new cables. This happenned after a 29 minute flight test tied to the bench. The pixhawk still works, will arm, etc.


I even tried a second computer. no luck.

First off, what version of the MP are you using?
The baud rate should be 115200 and the com window should say “com x PX4 FMU com x” where x is the Pixhawk com port number.
Are you waiting until the Pixhawk has gone through the boot loader tones and has completed the USB connection tones before connecting over MavLink? I assume that you have the Pixhawk speaker attached so you can hear the boot up and USB connection tones?
I presently use a USB powered hub and have had no problems connecting and disconnecting with my Pixhawk using MavLink after the second set of tones.
TCIII Developer

I am using MP 1.2.92

I am seeing the com port on the list where it says Com 3 PX4 FMU like it should, it used to work by just selecting this option .

I broke the connector for the speaker so I unfortunately don’t have that attached, but presently it has been connected for about 5 minutes, and it still just times out by both methods.

I just tried going back to my main computer and trying to connect with the terminal. I am able to connect on that computer through terminal, but not through Com3… No wait I was able to connect through Com 3 when I changed the rate back to 115200… I don’t get it?

Back to won’t connect again by radio or USB. Just worked that once when i connected first through teh terminal then through the regular connect.

I also plugged in the speaker, the noise it gave me was dot dot dot dash dash dash

Is there a link to what the speaker tones mean? I suspect that this isnt a normal tone.


Thanks for the help, I actually found the answer in another thread here, the SD card needed formatting. Why did this happen randomly and how do I prevent it next time?

There is a problem with the firmware and some SD cards, Today a beta version has been released (3.1.1-rc1) to improve the reliability of the SD cards (also corrected other bugs). You can test if you want, or you can wait for the next stable version that will include this fix.

You also can try another SD card.

alright thanks again. I guess this is solved

I have the same problem , and windows in a virtual machine says fmuv2 no driver found
i am running 3.6rc11.