Pixhawk won't boot because of magnetometer - it is not the c

Ok, I got my brand new pixhawk today and this is really annoying… The device won’t boot up, I got the well known “compass not calibrated” entry in my logfile. There were many people out there having quite the same problem, but 95% of them used the wrong five-wire-cable at first.
I have the problem with my six-wire-cable connected. Even tried another pair of cables. The boot-up is quite fine if I a connect the “old” external magnetometer from my APM 2…5 I tried calibrating with old mag, then boot with new, no success. Boot with old, calibrate with new, reboot, no success. Is there any possible solution left? Read something about temporarily deactivating some checks in the bootloader, but guys, you can’t be serious wanting people to do that, or do you?
Thanks for your help in advance!

To connect the 3DR GPS/Compass module to the Pixhawk requires a 6 conductor cable and a 4 conductor cable that should have come with the GPS/Compass module. The compass is powered by the GPS connection and not by the I2C connection where the compass cable should be connected.
Can you boot up successfully using the Pixhawk built-in compass?

Hey, that was really fast. No, if I connect the 3DR-Module with the correct 6 and 4 wire cables, I can’t boot the device, getting two beeps at the end of the boot-melody and the error-entry in the log-file.

Forgot a part of your question: If I disconnect the compass-cable (4 wire), the pixhawak boots successfully.

Sounds like you might have a bad compass on the GPS/Compass module and you should contact 3DR at help@3drobotics.com

I bought both items from a local dealer here in Germany, so I think I will have to return both as I can’t really tell which of the items is faulty. I will tell you about the outcome.

Hi AJ,
I had exactly the same problem and solved in the following way. Turns out solution was to plug the GPS 5-wire connector in properly. It was installed with 5 position plug in GPS and 6 pos plug in Pixhawk. In GPS the 5 pos plug was one pin to right causing problems. When MAG not connected problem also disappeared. Correct way is with 6 position plug in GPS unit and 5 position plug at other end of the 5 wires plugged into left most position of 6 position GPS socket on Pixhawk. I believe this will solve the problem.

Further to my last post. I tried connecting the GPS to the Pixhawk using a 6-wire connector that came with the 3DR telemetry radio. The problem reappeared as described previously. So it seems that a 5-wire cable is required and not a 6-wire as described in the Pixhawk manual.

I have five genuine 3DR GPS/Compass modules and two genuine 3DR Pixhawk FCs.

All five of the 3DR GPS/Compass modules have a DF13 six pin connector for connecting the GPS to the Pixhawk FC DF13 six pin connector.

I use a six wire cable to connect the GPS to the Pixhawk GPS connector and a four wire cable to connect the Compass to the Pixhawk I2C connector.

I suspect that a dealer has sold you a clone GPS/Compass module as a five pin connector on the GPS module is not a genuine 3DR GPS/Compass configuration.

TCIII ArduRover2 Developer

I too experienced this problem. I purchased my Pixhawk + compass/GPS at unmannedtechshop. The Pixhawk was delivered with a 6-pos to 6-pos cable, and GPS/MAG unit was delivered with a 5-pos/6-pos and a 4-pos cable. Turns out the 5/6cable is not needed anywhere, and one should use the 6/6 cable. They can be hard to tell apart at first, though, plus there was no documentation regarding this.

Anyway mine works now! :slight_smile:

Ok now I am indeed perplexed. One compass/GPS module was from authorized dealer in Germany and the other was directly from 3DR in the States. Both shipped with the same 6pin/5pin cable which works perfectly if plugged in right. Both have only five wires. Both have inspection stamps. The most recent is from 3DR USA and was inspected on Feb. 13 2014. So to be clear I do not have a problem but I can see how having different versions floating around could lead to confusion.

You need to use the 6pin - 6pin cable that was supplied with your Pixhawk