Servers by jDrones

Pixhawk with jumper R8 and FrSky telemetry passthroug not work

Hi,
I can’t get telemetry from the pix in yaapu widget,
Does anyone have it working and can you help me?

-Receiver is Jumper R8
-Horus transmitter with opentx version 2.3.4 with the yaapu version1.8.1 widget
-pixhawk 2.4.8

Yaapu I used this guide https://github.com/yaapu/FrskyTelemetryScript/wiki/How-to-run-the-Yaapu-script-on-X10-and-X12-as-a-Widget#how-to-access-the-script-configuration-menu-while-in-widget-mode.

The jumper R8 receiver is linked to the station

In the ardupilot I tried
SERIAL2_BAUD 57
SERIAL2_OPTIONS 0, 4, 7
SERIAL2_PROTOCOL 10

The connection between pix and the jumper R8 receiver is direct like here: https://www.jumper.xyz/portal.php?mod=view&aid=21

Thanks

Atila,
This issue has nothing to do with Mission Planner. Please move your question to the appropriate topic (Hardware/Radios), where those who can answer it will notify.
A detailed wiring description will also help (first I would check TX/RX line swap) Plus will try with SERIAL_OPTIONS 0, since most likely the inverter and pullups are already implemented in the receiver.

Thanks for your answer,
I will try to alternate the tx / rx lines.

I don’t know how to move the question to another topic. If any admin can move it, Thanks

I have configured firmware serial2_options 0.
I tried to exchange the tx / rx lines.
It does not work,
The transmitter don’t discover sensors, I follow the manual, leaving the sensor search active and displaying the yaapu page.

A little more help.

Thank you.

I have the same problem now,
Four weeks ago I had it working , but with a previous version of Mission Planer, Arduplane 3.9.9 firmware and the yaapu script version 1.7.x .
Now the new 1.8 version and the copter ( heli) firmware 4.0 does not work together anymore
Sorry, tomorrow I must search for the correct version of this script . …a little too late now

Edit: the controller is a RL Mini Pix V1.0. …receiver a Jumper R8 ( both serial ports don´t have an inverter, just for your info)

Edit:2 Got it. Just had to disable rts/cts…everything else was ok ( 57600/ 10)

R8%20to%20MiniPix

Thanks,

Don`t discover sensors in yaapu 1.8.1

I have in arduplanet 4.0.3

BRD_SER1_RTSCTS 0
BRD_SER2_RTSCTS 0

SERIAL2_BAUD 57
SERIAL2_OPTIONS 0
SERIAL2_PROTOCOL 10

can you send mi, your config file arducopter?
for check with mine.

This is mine Test.param (17.5 KB)

Belief me or not, I had it running this night, but this morning, I would just test my 4in1 which had not worked with this telemetry and it did not. So I bound the receiver again to my internal XJT (QX7) and even this does not work again…F…

OTX 2.3.5 , Yaapu 1.8 , Arducopter 4.00
I didn´t change anything on setup since this occurred again. Now I am on Arducopter 4.0.1 and start again to investigate and try to reduce the points which could be responsible for this problem.
A picture from tonight…

The last thing I can do, put both receiver serial lines on my logic analyzer and
watch the data.

Thank you. Keep me informed.

Issue solved!
The newer firmware seems to have a hotfix for the false imprint on top of the box for the serial ports…port 1 on top is port2 on the pcb…etc.
Since long I had this corrected with stickers…;-)…but now my stickers are wrong. Shit happens.

Atila , now I will check your Test parm.

I am Happy for you.
I keep trying swap telemetría Port swap.
Do not discover sensors.
I don’t know what to try anymore.

I have been reading a lot of documentation, and I think the problem is caused because rxbt value is 0 on the jumper r8 receiver.

Then when I get home I’ll try

it does not work.

in previous versions telemetry did not work if rssi or rxbt were zero.
In the current version it does not work only when rssi is zero.

some help?

oday I received a new receiver, and when I try it, it works perfectly.

Did you get the new ( blue) pcb? The the pcb has now a completely different circuite.

Btw. you can try now a different firmware on the old one.Now even with multibind.
https://www.rcgroups.com/forums/showthread.php?3504875-Jumper-R8-Receiver-8-channel-PPM-16-channel-SBUS-D16-LBT-D8-compatible-firmware

Servers by jDrones