Servers by jDrones

Pixhawk with ADS-B. Help

I just got the pixhawk 2 board with adsb but I can’t seem to get it working. I have a ping that works great. What port does the AFSBn tie into on the Carrier Board. I think that is the setting that is incorrect. Any help would be awesome. Thanks

I usually plug them into telem 2. Any serial port works so long as the baud rate is correct (57600) and the com protocol is mavlink or mavlink 2 depending on your ADSB in device.

As long as ADSB is enabled you should be good to go.

If your checking for data on a ground control station make sure it’s set to actually request the ADSB data.
Parameter STn_ADSB where n is the number of the serial port that you connected to.

@Sean_Fuerstenberger - If it’s the ADSB built into the carrier board then it is Serial 5. Please refer to to the following link and excerpt from that page:

https://docs.cubepilot.org/user-guides/carrier-boards/ads-b-carrier-board

To enable ADSB in Ardupilot to detect aircraft on ground station you need to be using Copter or Plane 4.0 onward for the Cube Orange and set the following parameters

  • ADSB_ENABLE = 1 Enable ADS-B (Disabled as default)

  • SERIAL5_BAUD = 57 Set baud rate

  • SERIAL5_PROTOCOL = 1 Set protocol

  • SR0_ADSB = 2 Set ADSB stream rate to ground station

Note: You may need to set SR1_ADSB = 2 to enable receiving on ground statiion on Telem 1 or SR2 for Telem 2.

Yep the above should sort it, the one to watch is the bottom line as that’s needed for telem port

It should work fine on the above setting, I also did a video on this on YouTube on the full setup

Servers by jDrones