Pixhawk will not allow motors tests

I am using a Pixhawk with my IRIS which suffewred a major crash. I had to resolder broken wires on one of my motors RED-RED. Blue-Blue, Black - Black.

Then I upgraded mission planner to version 1.3.5 and Arducopter to 3.1.5 and loaded to IRIS Param file just ot make usre all was current.
When I go to MP I try to do a motor test from the terminal mode by selecting PIXhawk. I get connected and type in test, then motors and connect battery. I get nothing. Next I go to MP initial setup optional hardware motor test and I get a message “Autopilot will not allow” (or something similar)

I cannot get my IRIS to test but can do all other calibrations yet the motors will not arm or spin up.

Any suggestions ?

PS I have searched to forums in vain but if there is an answer out there please gently guide me to it. I have not intention of abusing the forums.


Ron Burns


Have you tried just running the ESC calibration over again? I haven’t been able to get those motor tests in mission planner to work either, and I assume it has something to do with the unit being in a particular state. I just tried a few configurations on mine and no luck.

Hopefully this is some help:

Tried ESC calibration and most other test. 3dr agreed to send me a replacement Power Board on condition I send the old one.

Butttttttttt it sounds to me that this could be a software issue as all seemed to work until I did the upgrade. As soon as I get the replacement part installed I will run all tests and post the results.

My process

1 Rebound my radio
2 Calibrated Radio
3 Attempted to Calibrate ESC with no positive results.
4 followed instruction posted by Joe at 3DR posted on UTube.
5 never got a high throttle or low throttle signal just got Beep, Beep, Beep (3 cell battery) Beep, Beep and nothing.
6 I communicated with Fernando at 3DR and came to the bad Power Board conclusion. we will soon know right or wrong.

Sincerely Ron

Yikes, yeah, I guess it’s possible the crash damaged more than you know. Someone with more experience than I might recommend using a voltage meter to make sure your repair worked. I’m not sure how much shipping back to 3DR is, but I think new motors aren’t too bad, so maybe that’s an option.

Anyway if it’s a software issue I guess that wouldn’t help anyway. Your description of step 5, you’re saying they enter into calibration mode but don’t acknowledge when you move the throttle down to 0? Or am I misunderstanding? From personal experience if I’ve gotten it to recognize that the throttle was up twice during powerup I haven’t had any issues, so that’s an interesting problem if that’s the case.

I don’t know if your plan is to monkey around anymore or wait for the part from 3DR but keep us updated!

Sorry the step in step 5 was meant to address the ESC calibration. The Process is to power on your RC go to high throttle … once you disconnect and reconnect the battery you should get the standard beeps and then a long tone ( or beep) indicating that the High Throttle was captured and then go to Low Throttle and wait for a tone ( beep) to indicate that the low throttle was captured. Neither of these tones ( beeps) occurred, other than the standard 3 beeps, 2 beeps. the led does cycle through the colors as mentioned.

I did and have considered that the motors may have been a source of the problem but I do have to do a process of elimination.

I am almost ready to give up on the IRIS as I. Have had nothing but bad luck ( not lack of skill I fly two other quads without one tenth the problems) but I am not ready to give up yet. I can tell you that the original $795 has more than doubled with less than 50 flight hours.

Oh well guess I am just tired right now so no more until I can fully identify and fix this problem sometime early next week. Will let you know what happens


One thing to note (you might have meant this but sometimes semantics are important with this kind of thing) is that you need to throttle up to 100% and then power up the unit. Then leave at 100% and unplug and replug. On mine (I have the DIY kit not the IRIS) I then have to make sure I hold the safety switch to ‘arm’ it into calibration mode.

Like I said, maybe that’s what you already did, but I thought it was worth at least mentioning just in case. I wasn’t getting the extra tone to signify that it had recognized the first boot with 100% throttle and it was very obvious the first time it worked. My issue was totally different though – my throttle wasn’t bound to CH3, so when I was booting at 100% throttle it was actually seeing it as 100% of a different input.