Pixhawk USB problem, FMU and IO PWR leds only flicker

I have just received my pixhawk yesterday and I am trying to start the setup process. I have unfortunately encountered an issue that seems to be hardware related.

A) When the pixhawk is plugged in to the USB the FMU and IO PWR LEDs just flicker/pulse.
B) The device manager on the PC/Mac does not detect a new device.

This problem is reproducible without anything plugged into the pixhawk, with just the power module or with the buzzer, switch and power module attached.

After looking through the forms it was possible that the PC was not supplying enough current so I tested it with my Mac laptop, PC and then again with powered USB hub. The results were all the same.

The issue seems to be located with USB. When the pixhawk is powered through the power module the status LEDs seem to indicate proper operation. The FMU PWR and B/E are on. The IO PWR and B/E are on and the activity LED is flashing.

I have made a quick video demonstrating the problem.


I would appreciate some advice as to what to test next or who I should contact to have this issue resolved.
Thank you

Are you sure that you are not using a power only USB cable that only supplies power for charging and does not have the TX and RX connections?
Have you tried another known good USB cable?

Hi uavDroid

Please try on using a powered USB HUB.Some USB ports can’t supply enough power by itself to get a successful startup on the Pixhawk.


He already stated that he had tried connecting with a powered USB Hub and still experienced the same issues.


Please contact to help@3drobotics.com requesting an RMA# to get a replacement. Don’t forget to include your order number.



Are you sure that you are not using a power only USB cable that only supplies power for charging and does not have the TX and RX connections?
Have you tried another known good USB cable?[/quote]

This is a good point, also what you can try is to power the Pixhawk with the power module and to connect the USB cable, with both connections, if you are able to communicate the Pixhawk with mission planner or apm planner that means the USB cable has the Tx/Rx lines and the problem is the Pixhawk.

Thank you everyone for the replies. They are welcome and I agreed this is an usual problem.

I did contact the help line. They wanted me to do two tests and after I gave them the results they sent me an RMA number. It is currently on its way back now. I should have better results with the second board as I want a more reliable alternative to the custom autopilot hardware I developed based on the Robovero. My custom solution has too many wires and connections (points of failure).

The first was the powered hub test. They were worried about the current limits. Just for fun I tested a USB 2.0 (should be rated at 500 mah) I can see this not working, I can not program the Robovero this way ether, a USB 3 (specked to be able to supply 900 mah) a USB but with a 2 amp supply and lastly I even tried my ipad 2.1 amp charger. The results were all the same, just the flicker. I know the charger would not have anything on the Rx/Tx pair but it was defiantly enough power available to boot the board but it behaved the same every time.

The second test was the same test RogelioN suggested with powering the pixhawk from the power module and then plugging in the USB. This did boot and allow my computer to detect the hardware and it installed the proper driver. That was a good start and proved the USB cable was ok as well. I wasn’t able to load any firmware though.

One funny thing about the board I received is that it would never boot if I plugged in the USB first. Even if I added power from the battery afterwards it would still keep trying and failing to use the USB power. I could only get it to boot if I plug in the battery first and then the USB. From what I know of the system (please correct me if I’m wrong as I would actually like to know) powering the pixhawk from the battery and then adding the USB makes it impossible to load firmware since you can’t drop into the boot loader.

I look forward to receiving my new unit and will try again.

Have a good weekend

I believe that you might be able to program the Pixhawk when using both battery power and the USB connection by rebooting the Pixhawk using the FMU reset switch located by the USB connector which starts the boot loader allowing the GCS to program the Pixhawk.