Pixhawk twitching problem

I have a nasty problem with my setup and I can’t find a solution for it. That’s why I’m asking for your help.

The copter is hovering without GPS support. After a short time the copter twitches to a side and catches itself again. After several seconds or even minutes it happens again.

Here is a video of the problem:
[youtube]- YouTube

Here is the log:

As you can see are there two negative peaks. These are the twitching’s. The bin-file is attached.

Controller: With the DJI Naza M lite the copter flies great and I had never such issues.
ESC’s: I exchanged the DJI OPTO 3A ESC’s with TBS Bulletproof 30A ESC’s (exactly the same)
Auto tune/tune the PID parameters: The copter react faster on the failure but it still happens.
Firmware update: I had the same problem with 3.1.3 and 3.1.5
GPS: the problem occurs with and without GPS support.
ACC recalibration: I thought it could be caused by a faulty calibration of the accelerometer but a recalibration didn’t solved the problem
THR_MIN: I found information to increase this value, but it seems not to change the bad behaviour. http://copter.ardupilot.com/wiki/troubleshooting-2/#My_copter_flies_well_but_then_dips_a_motor_arm_in_a_fidgety_manner_while_hovering

Frame: TBS Discovery pro
ESC: TBS Bulletproof
Motor: T-Motor 2216
Props: Graupner E-Fly 9”
Controller: Pixhawk
GPS: uBlox
RC: Futaba T8FG Super / R7008SB

Could someone help me with any idea? I have no clue what I could do more… :confused: Thank you!

I spend again a lot of time in analysing this misbehaviour. I contacted also the helpdesk of 3DR and they are really helpful. But unfortunately they didn’t locate my problem.

In my despair I reset the PH by installing the Arduplane and then the Arducopter Firmware again. This didn’t solve my problem but enabled the logging of RCIN an RCOUT what revealed the following log information:

In this diagram you can see the twitching on the Roll-axis which correlates to movement shown in the video. Additionally you can see the RCIN of channel 1.

I realised that every time I got a twitch the RCIN on all RC channels goes down to zero and immediately back to its idle PWM rate and the copter follow this input.

This diagram shows a closer extract of just one twitch:

To be sure that this input occurs also on RCOUT I compared these two signals. It’s clearly visible that the PH put through the “wrong” input (caused by vibrations) auf the RX to the ESC’s what trig-gers that misbehaviour.

So far so good, I exchanged the S.Bus cable in the field and hoped it’s the culprit. But I have had no luck and the misbehaviour still remains…

I have to connect my oscilloscope at home and try to replicate the flight vibrations to localize the faulty connection.

Possible reasons:

  1. Connection RX and PH
  2. Futaba Receiver
  3. Pixhawk RX connection port for S.Bus or any other hardware issue

Had anyone similar problems how can share his experiences with me to solve my problem?

The problem is solved!

The reason was the mode of the Futaba R6308SBT receiver. This receiver offers two modes: “normal” and “high-speed” (default is “normal”).

As soon I changed the mode to “high-speed” (& telemetry off) the response time of the RC inputs was much more precise and the negative peaks to 0 were gone and therefore also the twitching problem. I assume the problem is a sampling mismatch between the Futaba “normal” mode and the PH.

Here the manual to switch the mode:

I assume this could help also with other Futaba receivers which are not well supported.

My X8 is exhibiting these exact same symptoms. However I’m using a FrSky D4R-ii receiver. I’ll need to do some digging to see if there could be a similar issue with this receiver. I know this receiver needs a firmware update to be used with the Pixhawk which I did do. I may try to flash it again in case it didn’t update for some reason.

Unfortunately I have yet to be able to download a log file as it times out midway through the download every time I try. Thanks for your diagnostic work. This might get me on the right path.