Servers by jDrones

Pixhawk Throttle Issue

Hi! I’am trying to make a fixed wing airplane but I have some problems. I cannot use my engine. I plag into 3th main out port it. Other servo motors I plug in are working but engine isn’t. When I oppened my Mission planner program, I realize that i can see 3th channel mooving in calibrate radio tab but not in servo output tab. I added a video about my problem. What should I do? What do you recommend? Thank you from now.

About problem

For the throttle to output the plane needs to be armed. Also, if that beeping is your ESC, it’s another clue that the ESC is powered but not getting the minimum PWM. With the prop removed, arm the plane and see if it works.

Firstly, the tool that beeping is our engine, not ESC. When we take out pixhawk from our system, the engine is working with ESC. How can we power our engine with pixhawk?

Yes, the motor is making the sound because the ESC is sending the signal to the motor. The ESC is doing that because it’s still getting a signal that is below what the ESC expects. Probably 0 PWM. As a safety Arduplane will not send anything to the ESC/Motor until you’re ready and have it armed.

Try setting ARMING_REQUIRE = 1 to turn off the beeping.

Have you armed the plane?

https://ardupilot.org/plane/docs/arming-your-plane.html

I try this solutiun but this ARMING_REQUIRE settings was already 1. Yeah I armed but nothing changed. When I try different ESC and motor, it worked. I dont’t know. I confused.

If the ESC is still beeping like that it means it’s not getting signal it’s expecting. So the initial signal it’s getting is either too high or too low for that particular ESC. Have you done the calibration yet?

Servers by jDrones