Pixhawk take off on one side

Hi everyone,

I know this question came out multiple time but I’ve tried pretty much everything I could find.
I have a “V” quadricopter with arducopter 4.0.5 firmware.

  • I’ve calibrated the sensors
  • motors and wings are connected properly
  • calibrated ESCs
  • trims on my RC are in the middle

and yet the copter only rise to the right.

I tried to take off in “stabilized” and in “loiter” mode as suggested here Drone does not take off, wants to fall on its side!
but nothing changed.

I attach some log files, probably i can’t read them the right way.

I’m pretty new to the world of drones but with px4 I was able to fly straight, maybe not stable but at least I could take off

Thank you


Did you run a motor order test? If the motors are not in the correct order it will tip to one side.

Are you sure you need a V Frame firmware configuration? if it looks like a Dead cat some think that’s a V but they will generally fly better on X. I don’t know what you have though.

Thank you for your time

I’m pretty sure the motors are disposed and connected correctly, I’ve controlled many times numbers, connections and directions

This is new to me, looking at the “arms” shape I assumed it was a V but never tried with X, tomorrow i’ll give that a try. In fact it looks like a dead cat

Thanks again


I have had those frames and always used X. I don’t know if it will solve this particular problem but it’s probably the right thing to do anyway.

Good evening,

I’ve changed the configuration in X, I’ve repeated the calibrations once again, but nothing happened.

Motor test goes flawlessly.

Is that possible that the alimentation board doesn’t give the same power to all motors? it is a simple board where I’ve welded 5 connectors (1 battery and 4 motors), the last thing i can think is that it could be faulty.
As I mentioned in the first post, some time ago i could fly, so i woud exclude faulty hardware from the causes, but you never know.

Here is a video of what happens

Thank you,


Did you perform a radio calibration? Because your Elevator Trim is at 1000 (RC2_TRIM,1000) Center all trims on the Transmitter and re-do it.

Have you done a level cal in mission planner before take off? I’ve had something similar happen until I hit calibrate level:
VID-20210106-WA0008 (1)

I don’t think that’s advisable. You want level to be from a level reference (bench) not from whatever ground you are on when you take off.

He has a trim problem. If you start with an elevator trim at 1000us you have done something wrong.

You are great and I will never be thankful enough

@Yasiinm i thought the same but actually dkemxr is right, for what i understood the autopilot should know where the exact flat level is and not the level of the ground. I’ve tried many times to calibrate level as flat as possible, maybe it won’t be perfect but i think the error is under 1°

@dkemxr wow, that’s strange, i did calibrate the controller and values are ok (1000-2000, i don’t remember precisely) and moving them i can’t see anything unbalaced, but if you read that from the log i must be wrong. Unfortunately i can’t do anything until next thursday but this could be very precious.

Thak you very much guys, i’ll let you know


Hi guys,
I checked the RC channels and found that they where actually different from the standard 1, 2, 3, 4, so the 1000 trim in RC2 was due to the fact that it was a switch and not a stick, if that could be. Anyway I connected the right channels from the receiver to the PPM and now the values are the normal ones. All the trims are 1500/1499 now, exept for RC3_trim (throttle) which is 1000.

Unfortunately nothing changed for what concern the take off, but i noticed that one of the motor doesn’t start when i arm while the others do. It starts only with a bit of throttle. I tried to switch it with the other and see what happen: a third motor starts doing the same so I think is not a big problem. The puppy still stand on two legs :c

This is a log of a brief attempt with the new settings.

Thank you, really.

P.S. i noted that sometimes when i turn on the drone the ESCs make slow beeps until i press the safety switch for arming. I could’t find an explenation online but it happens only once in a while.

Calibrate the ESCs. And follow the “tuning process instructions” on the ArduCopter wiki

Giulio, I don’t think you have anything wrong. Many multicopters will start flying stronger on one side vs another until it gets off the ground and can get out of ground effect.

I think you just need to be bold and give higher throttle to quickly get it off the ground a few feet. It should then recover and hover correctly as long as your multirotor is balanced and does not have more weight on the one side.

1 Like

Hi everyone,

I have some news, I resetted the pixhawk, unmounted everything and mounted it again. Recontrolled motors, calibrated ESC and sensors, placed the battery in a more secure and rigid place and…
the same problem is now on pitch: It rise only on the front.

I tried to keep it up from the ground and make it loiter from my hands, it worked. It has a little shift but it’s understandable.
I think the weight is well placed, I tried to move the center of gravity to undestand if it was the cause but it seems not.

I don’t know, maybe @mike you’re right, do you think the automatic take off would help?

Thank you,


Ardupilot has no choice but to assume your aircraft is balanced correctly before take-off. After takeoff it uses control theory to refine guesses at what is needed to hover and fly correctly. Buit before it gets any data, after take-off, it must assume you are balanced. SInce the tilt moved to pitch after rearranging your components you might take a string tied to the center of thrust and see if the aircraft hangs level and is balanced.

After you get it balanced as good as you can then you just have to be bold and give it enough throttle to get it off the ground far enough for the control feedback to start controlling the motors.