Pixhawk startup unhealthy?

I have a new pixhawk, right out of the box. I’m still waiting on parts, so I thought I’d mess with it, but I’m wondering if it is healthy.

In searching this forum, I’ve seen similar (but not identical) symptoms; sometimes they mysteriously go away, sometimes the thread just ends, and sometimes the thread has seemingly contradictory info about what the LEDs mean.

Video Version

I do this:
…and I think it is not starting up correctly. After the video, the state does not change for minutes and minutes.

Text Version

Here is what I do:

  • plug in the buzzer so I can hear it
  • plug in the switch so I can see its light
  • plug the pixhawk into a USB port

Pixhawk starts up.

FMU PWR LED goes steady green, stays green forever.
FMU B/E LED blinks rapidly for 4-5 seconds, then goes off forever.

I/O PWR LED goes steady green, stays green forever.
I/O B/E LED blinks rapidly for maybe a half second or less, then goes steady orange, stays steady orange forver.
I/O ACT LED starts blinking at 2 Hz right at power on and does that forever.

The “main” LED never lights up.

About a second after the FMU B/E LED stops its rapid blinking, the buzzer plays the happy sound, as if everything is okay (I think).

The switch light is blinking red rapidly, faster than the blue I/O ACT LED, slower than the amber FMU B/E LED was blinking.


Nothing ever comes out of the serial port.

I’ve tried several USB cables, on many USB ports on two computers, and two USB chargers (0.7A, and 1.0A); changing does not make a difference.

I have tried reseating the SD card several times.

I have pushed the button in the side next to the USB port. The only difference I see between that and the cold power-on startup is the IO B/E LED stays steady amber through the reset.

I tried letting Mission Planner connect to it, but it would not (as I expected).

I think what I should see is:

  • both green LEDs stay on steady
  • both amber B/E LEDs eventually go out
  • ACT indicates GPS status, probably blinking at some rate since it is not hooked up
  • the main LED starts flashing multiple colors

What else can I try? Thanks!


Well if you never connected it to Mission Planner and load the Firmware than I would say this is normal.


I was initially trying to get it to connect to mission planner, but when could not do that, backed off to basics (I thought). Mission planner just times out waiting for it.

  • shouldn’t there be something coming out the (usb) serial port when I power up or reset it?
  • shouldn’t there be some version of firmware in it when I first get it?

Thanks for reading,

John that is the same thing mine did until I installed the firmware. The way you have the Pixhawk set up now is correct for installing the firmware. Just install Mission planner on your computer first and follow the firmware update procedure and the Pixhawk will start responding. Make sure you use a good USB port on the computer as the Pixhawk draws a fair amount of current during the update.


Thanks Mike and Matt. I tried Mission Planner again, doing this:

  • Plug in Pixhawk, let it settle
  • Start Mission Planner
  • Click Initial Setup / Install Firmware
  • Click Quad, Ok
  • Unplug/replug Pixhawk
    (LEDs/beeps the same as in the video)
  • Mission Planner appears to detect the com port (status messages in lower left change quickly)
  • After a short while (30 sec timeout?), it pops up a dialog “Error uploading firmware”, and in the lower left, says “ERROR: No Response from board”

I tried with two different ports on my laptop, and one port on a powered USB hub. All of those ports seem okay with a different Pixhawk (and Mission Planner talks to that Pixhawk).

A couple more things I tried:

  • I took out the SD card just to see, and I do get the “SOS” beep pattern, so something is seeing the card correctly (then I put the card back in)
  • Hooked up the nuttx console, and don’t get anything there (using the same cable to the other Pixhawk and I get the shell)

Gotta be something goofy I’m doing… thanks for reading!

The only other thing I did was to format the SD card. Not just a quick but the full format using the default values. HTH


Thanks Matt. I tried the full-format, then tried a different brand 1 GB card.
I think I’ll have to see what 3dr support says.

It works now. Mike had it right; the missing piece was why Mission Planner would not connect to load the firmware.

It would not connect because I run MP in a virtual machine (Ubuntu native + VirtualBox + Windows 7 VM). The Pixhawk USB device was “statically” mapped through, but when you plug in a Pixhawk, the bringup of the USB port still has to go through the layers: Linux detects it, sees it goes to VBox, Vbox gets it and brings up the port. So the added delay in doing that was too much, and Pixhawk could not be stopped in the bootloader. It works fine to connect to a Pixhawk that already has firmware, but the VM-based Mission Planner (mine, at least) can’t stop Pixhawk in the bootloader.

Pixhawks are indeed shipped with only the bootloader, so (as Mike said) you have to do the firmware install before it’ll do anything.